Support » Plugin: Kirki Customizer Framework » WOFF Files generated in uploads folder

  • Resolved boconpro

    (@boconpro)


    Hello,

    we are using the Kirki with the Unero Minimalist Theme.
    It looks like since a few days Kirki generated WOFF files in our wordpress upload folder, almost every 2 seconds a new one. I just deleted 10GB of Woff files.
    We didn’t do any major changes on our website. Do you have any idea what might cause the problem?

    I would appreciate any help!

    Regards
    Thomas

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • xiano8494

    (@xiano8494)

    We are seeing the same issue, filled 30GB space in 2 days.

    Plugin Author Ari Stathopoulos

    (@aristath)

    Hello @xiano8494 and @boconpro,

    Are you both using the “Unero Minimalist Theme”?

    I just tested this with 3 themes and so far I can’t replicate the issue you are describing. I can see a single .woff file downloaded for the font-family and no extra files seem to be getting created in the uploads/2019/06 folder as I browse the site.
    However, I don’t have access to the theme you’re using since it’s a premium theme. I can’t test what that theme does, and don’t have access to its code to see how they are implementing Kirki and what goes on behind the scenes.

    The only thing I can suggest without knowing anything more about your sites would be to simply go to the customizer and make sure you have valid settings for your typography fields.

    Have you tried contacting the theme author?
    Premium theme authors could login to your site and debug the issues you have, something not allowed on wordpress.org tickets.
    Your theme developer should be able to help you.
    This seems more like an implementation issue to me or specific to your environment, but if it is indeed an issue with Kirki the theme-developer can share their debug findings with us so can fix it.

    Plugin Author DannyCooper

    (@dannycooper)

    This is most likely because WP_DEBUG is set to true in wp-config.php

    This will undoubtably be fixed in the next update, but for now you might want to set WP_DEBUG to false to stop the constant downloads.

    Plugin Author Ari Stathopoulos

    (@aristath)

    v3.0.44 is being uploaded right now and includes a fix for this issue.

    agassi6060

    (@agassi6060)

    I’m having the same issue using the KnowAll theme by herothemes. .woff files are being generated in my uploads. Could you provide me any insights?

    Plugin Author DannyCooper

    (@dannycooper)

    .woff files are supposed to be generated as Kirki loads Google Fonts locally.

    If hundreds or more files are being generated then you will likely need to update the Kirki plugin or ask your theme developer to upgrade their implementation..

    • This reply was modified 2 months ago by  DannyCooper.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.