Support » Plugin: Dynamic Audio Player Basic » Wocommerce

  • Resolved salilou

    (@hkr)


    hi again
    I want your dynamic player to appear at exact one page and no other
    this I solved by setting include page id in widget settings according to your hoot
    now I face the following problem:
    the player appears on the page which is defined as woocommerce shop main page
    I use woocommerce and x theme with fullwidth without sidebar
    wordpress, theme and all plugins are up to date
    thank you for your support

    https://wordpress.org/plugins/dynamic-audio-player-basic/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author msalsas

    (@msalsas)

    Not sure, but could you try adding this page id to “excluded pages”? Also, there is a “show in home page” option. You may have this page as your home page…

    Thread Starter salilou

    (@hkr)

    I have already added the page id to “excluded pages”
    the shop main page is not the start page of the website

    Plugin Author msalsas

    (@msalsas)

    I’ve tried to reproduce the error without success. Try this:

    – Install https://wordpress.org/plugins/reveal-ids-for-wp-admin-25/ plugin and enable it.

    – Go to “Pages” and check ID in “Screen options” (top right of the screen).

    – Check the page ID for the “Cart” page, which is created by Woocommerce plugin and is supposed to be the Woocommerce main page.

    – Go to Widgets section and open the Dynamic Audio Player dropdown menu.

    – Put directly the ID number (without quotes) in “Exclude this pages…” and save.

    – Check again your “Cart” page.

    Thread Starter salilou

    (@hkr)

    thank you, but I had already located the page id out of the link and added it to the “exclude this pages” field in the widget manager
    nevertheless I followed your steps – with the same result
    mh, what now?
    on your woocommerce installation the player doesn’t show on the shop main page?
    maybe it has to do with my general layout:
    I use fullwidth without sidebars an without widgets
    thanks again

    Plugin Author msalsas

    (@msalsas)

    Well, I only can recommend you to hack into the plugin to see what is happening. Open dynamicplayer.php, go to line 135 and write these lines:

    echo 'is page?' . is_page(); // should be true
    echo 'is home?' . is_home(); // should be false
    echo 'is page with ID yourID?' . is_page(yourID); // should be true
    exit;

    Then go to that page and see what is displayed.

    Thread Starter salilou

    (@hkr)

    thank you for the code
    I’ve integrated it and the result is the following:
    my shop main page shows: is_page()=FALSE and is_page(72)=FALSE
    I have tried the default shop main page (page “Shop”) instead of my custom page: the same result
    I have tried a standard wordpress theme (Twenty Sixteen): the same result

    Plugin Author msalsas

    (@msalsas)

    I’ve just updated a new version (2.3.0). Once updated, you can find a new option at widget section (Show in shop page (only for Woocommerce plugin)). Please, confirm that it works for you.

    Thread Starter salilou

    (@hkr)

    thank you, the new update works for woo commerce main page now, but not for the woo commerce product pages, where the player still is visible
    – and now the player doesn’t appear on my specific page (id 66), that I have set in widget settings
    – and the playlist suddenly is empty

    my settings are:
    exclude this pages: all
    include this pages: 66 (my specific page)
    show in shop page: false

    I have installed a completely fresh wordpress-website with the same results. only the playlist was ok.

    Plugin Author msalsas

    (@msalsas)

    If you set “exclude all pages”, all pages will be excluded, no matter if you include others. Remove this option.
    The playlist issues are due to the cookies. Clear them on the browser or open a private navigation window.

    I would recommend you to just include those pages where you want to include the player, and maybe exclude “all” in post.

    If this doesn’t work I’ll ask you for an other hack. Add these lines in dynamicplayer.php in line 192 (just before dyn_scripts($dyn_option);):

    else {
        return null;
    }

    I think this will work. I’ll update the plugin once you confirm this point.

    Thread Starter salilou

    (@hkr)

    this has worked – without the hack!
    cookies deleted
    exclude all pages: EMPTY
    include pages: 66 (my music page)
    by setting “exclude posts” to “all” I could hide the player on the product pages and the hack was not needed
    thank you for your excellent support!! 🙂

    Plugin Author msalsas

    (@msalsas)

    Great! You’re welcome. Thank you for your feedback. You can leave a review if you are satisfied.

    Plugin Author msalsas

    (@msalsas)

    Marked as resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Wocommerce’ is closed to new replies.