Support » Plugin: Plugin Organizer » with/without www

  • Resolved jlahm

    (@jlahm)


    I’m using Plugin Organizer to remove some plugins (like Woocommerce) from non-shop pages. I’ve noticed that when I enter the domain URL without the leading “www.” (which is my Site URL setting), it works fine. But, if I enter the domain URL with the “www.”, Plugin Organizer is not matching the page overrides allowing Woocommerce on specific pages. If I create a plugin filter and have it apply to both types of URLs, then it works. Is this the way Plugin Organizer is supposed to work, or have I made a configuration error someplace?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    If your site doesn’t have the www then entering that will never match a url.

    So, if I understand you correctly, when I set the enabled/disabled plugins using the Plugin Organizer portion of the page edit dialog, it will only apply to those URLs entered by people that match my site’s settings? In my case, since I defined the Site URL without the “www.”, if someone comes to the site using “www.sitename.com” then Plugin Organizer will not match on this address and thus not make the changes I specified. Conversely, if I set my Site URL to “www.sitename.com”, users who entered “sitename.com” would not match either?

    If this is correct, I assume that the “fix” is to add the appropriate entry in my .htaccess file to (in my case) remove the “www.” from the URL? The alternative is to define filters that match both forms of the URL.

    If this is all correct, it might be worth highlighting this in the documentation.

    Thanks for your help.

    Plugin Author Jeff Sterup

    (@foomagoo)

    No. That isn’t how wordpress works. If you enter the site address without www then all addresses are redirected to the same address without the www. Try it yourself and you’ll see.

    D’oh! I see what I did. For some reason, I was setting the WP_SITEURL and WP_HOME defines in my wp-config.php file. So, a user using “www.sitename.com” was setting the WP_SITEURL define to include the www. Fixing that mistake of mine does allow WordPress to properly remove the www on my site and Plugin Organizer should work just fine.

    Thanks for your patience. Error was entirely on my part!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.