Support » Fixing WordPress » With newest wordpress, large emoticons forced to display at "normal" size

  • Hello,

    I make HUGE usage of emoticons on a wordpress blog, and some of those emoticons are larger than the default 15×15 (or was it 16×16 ?) emoticons, as far as 27×27 px.

    I’m using a plugin to add my own emoticons to my wordpress blog, called Custom Smiles : https://wordpress.org/plugins/custom-smilies-se/
    (oh my god I never noticed it hasn’t been updated in three years oh god oh god oh god)

    I know that fully, and I’ve managed to avoid breaking the display of my posts so far, by giving emoticons their own line, when they’re large emoticons.

    However, I noticed that since the latest wordpress update, 4.2.1, my large emoticons are forcefully shrunk to the default size or 15 or 16 px.
    Frankly, they’re now super ugly and worthless.

    Please, do you see a way to restore the way the emoticons used to look ? How to prevent them from being shrunk ?

    Thank you VERY MUCH if you can help !
    It’s a small detail, but hundreds of posts are now looking bad because of this…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Ah, small updates from my testing :

    – the Classic Smilies to restore previous Smilies functionaliti doesn’t help, it makes my personal emoticons with their own codes, like :woot: simply fail to show as images, what’s displayed is their text.

    Besides, it triggers a

    Plugin Security Checker: Security Warning!
    
    Classic Smilies (folder "classic-smilies") have been removed from official repository. Go ยป

    – the Disable Emojis plugin, tested first, didn’t change anything, my personal emoticons do show, but with their abnormally small – well, abnormally normal – size.

    EDIT : I don’t have time to test it this evening, I really need to sleep, but I’ll report my findings at least.

    style="height: 1em; max-height: 1em;"
    is now forced to my smileys, the legitimately 15px ones and also the others.

    One thing leading to another : https://wordpress.org/support/topic/thank-you-639?replies=2
    I do NOT have this plugin active, but see that it mentions that wordpress now forces things to smileys.

    Solutions : either test overriding it with 100% size in css, or find how to make wordpress comply.

    Sorry, no more time to test today, I had no idea I would find hints after posting my thread, and now I must leave an open thread like that :-/

    To solve the problem with the sizes, go to file wp-includes/formating.php

    in aprox the middle of the file, you will find the function translate_smiley

    go to the end of this function and f*** this line off (remove the bold part)

    return sprintf( ‘<img src=”%s” alt=”%s” class=”wp-smiley” style=”height: 1em; max-height: 1em;” />’, esc_url( $src_url ), esc_attr( $smiley ) );

    I just tested

    .wp-smiley {
    height: 100%;
    width: 100%;
    }

    In my theme’s stylesheet, and it yielded creepy results, a smiley trying to take all available width, suddenly 525 px wide, brrrr.

    On the other hand, the solution you suggested, Lamentira, worked like a charm, THANK YOU ! ๐Ÿ™‚

    I kept the class=”wp-smiley” just in case, simply removing the odd 1 px specifications (that left me puzzled, the smileys show up at normal size, not at 1 px O_o) was enough.

    It’s a relief!
    It’s true it’s a pity to have to manually update core files, hey, but I can’t complain, it’s much better than nothing, I’m renewing my thanks ๐Ÿ™‚

    ndop

    (@ndop)

    Thank you Lamentira, it works like a charm!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘With newest wordpress, large emoticons forced to display at "normal" size’ is closed to new replies.