Support » Plugin: MailPoet - emails and newsletters in WordPress » With each new version a surprise

  • I have the paid version, but the every new version wants to push you to use their MailPoet servers to send emails.

    I use AWS to send emails and send 16 emails per second, but now MailPoet only processes 1 email per second, regardless of the speed of the server.

    MailPoet message:
    That’s 15 emails per second. We highly recommend to send 1 email per second, at the absolute maximum. MailPoet needs at least one second to process and send a single email (on most hosts.) Alternatively, send with MailPoet, which can be up to 50 times faster.

    Before I used to shoot 15 emails per second … now it takes 3 hours to send 5000 emails.

    absurd to paid customers …

Viewing 1 replies (of 1 total)
  • Hi @marcelaopimenta,

    You can send more than 2,000 emails per hour. In fact, you can change the MailPoet Settings to send a lot more.

    We recommend 2,000 emails/hour as a safe value because it takes about 1 second to send 1 email due to bandwidth limitations.

    We also need to take into account our user’s server performance. Some hosts struggle to generate so many emails per batch.

    Running the MailPoet cron option will probably provide one of the fastest delivery speeds.

    If you’re comfortable by using filters, you could refer to this list: https://kb.mailpoet.com/article/274-list-of-filters-and-actions

    There you can change the batch size. Default value is 20, and you can increase it.

    However, we do not recommend increasing it too much because batch generation takes longer, and the process tends to hit PHP memory limits.

Viewing 1 replies (of 1 total)
  • The topic ‘With each new version a surprise’ is closed to new replies.