Support » Fixing WordPress » windows server hosted site – image upload issues

  • Resolved ladydelaluna


    Okay, so first thing I found here was this: however it’s Greek to me, and I think I need further support here.

    The site is currently being developed at – this is my client’s site, and is hosted with a company I’m completely unfamiliar with, on a Windows server (and I’m completely unfamiliar with that as well, as for the past year, every wordpress install I’ve done has been on a Linux server, but I can’t arbitrarily make the switch, because they have a current site up at the root, and I don’t want to do anything that will mess that site up while we build the new site in the backend here…)

    Anyway, when uploading images via admin using Firefox, the image will upload, but I get a fatal error saying it can’t do it. Then I refresh the browser, and the image is there, but I get a strikethrough on the thumbnail option. So I insert the pic anyway, and it looks fine (full size) after saving and viewing in FF – however, in IE, the image IS a thumbnail. When uploading using IE (as my client does), it shows as a thumbnail no matter what browser you view it in.

    Are you still with me here? I’m getting lost in this myself I think.

    The reply on the other post about this issue was:
    “You don’t have the graphics library extension enabled in your Web server.
    Not sure if the settings are the same for IIS, but for Apache, I had to uncomment out the following line in my php.ini file:
    Once that was uncommented and I restarted my Web server…”

    Okay, so I don’t know if this is IIS or Apache.
    I don’t know how to access the php.ini file.
    And I don’t know how to “restart my web server”.

    Ugh – I’ve been using wordpress for over a year now, and this is the first time I’ve ever been forced to use it on a Windows server. Can anyone help me?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Oh dear.

    Do you have access to the host server at all? Or is it a 3rd party hosted box?

    Hey HS – it’s 3rd party – I think it’s “Interland”?
    Apparantly the company’s related to because that’s where they keep trying to send me for support all of the sudden.


    Php.ini is typically something only the host can play with…. I was hoping you were going to say that your client owned the server.

    I believe you’re on the right track with working to get GD enabled though. Your host will have to install/enable it though.

    This is essentially the same reason I rebuilt my windows server to be a linux server 6 months ago. 🙁

    I should qualify that last line: Things like this triggered my decision.

    This is just killing me.
    I reallllllly don’t think my client’s going to let me make the switch to linux. And even if they do, I’m worried that it will affect the current website they have up in the root before I can get the layout and everything finished so they can populate the content and have a ready to go site up.

    And the hosting company is a pain in my ass already. Handing me the whole “we don’t support custom scripts” response to my questions about the server. I told them, it’s not the “script”, it’s the server. And they closed my ticket. Grrr.

    Open new ticket: Please enable PHP / GD.

    Don’t mention WP at all 😉

    I’ll give that a shot…and report what happens… *sigh*


    From the support ticket response:

    “Thank you for contacting technical support regarding your issue. We apologize for the inconvenience. Your account is already running PHP 4.3.0 with gd 1.6.2 support. You can view a detailed list of the PHP configuration settings on your account at: If you have any further trouble, please let us know, and we will be happy to assist you.”

    I went to the URL they gave (IP address) and saw this:

    System Windows NT localhost 5.2 build 3790
    Build Date Dec 27 2002 05:28:00
    Server API CGI/FastCGI
    Virtual Directory Support enabled
    Configuration File (php.ini) Path C:\WINDOWS\php.ini
    PHP API 20020918
    PHP Extension 20020429
    Zend Extension 20021010
    Debug Build no
    Thread Safety enabled
    Registered PHP Streams php, http, ftp, compress.zlib

    *** SO NOW WHAT!? ***

    I think I’m gonna cry…

    I wish we knew what version of GD is necessary. 1.6 seems a bit dated, but I could totally be off base. Maybe ask the hackers list if they know?

    I’m so tired of this issue. I’ve been stressing over it for two days now, and I’m beginning to think I need to beg my client to make the switch. After checking out the current site at the root, it appears to be all .html files, so I’m hoping that the switch to linux wouldn’t affect anything.

    I sure as hell am not going to ask the hosting company for their opinion on that, but it doesn’t APPEAR that it will cause any problems… am I wrong with that?

    If they’re plain ol’ “pure” html files, should be no biggie. If they got some FrontPage extension lovin’ going on, that can be handled via *nix servers too, assuming a half-bright host.

    Thanks, HS – I don’t happen to see any FP extentions (thank god… I think they used dreamweaver to build the site) but I’ll do a double-check on that.

    Thanks for your help today… at least you had me going in some sort of meaningful direction, even if the hosting company didn’t give me the love I deserved… LOL

    Keeping this as “unresolved” just in case anyone else has run into this and can provide a detailed answer for future people with this problem. It’s doubtful, but hey, why not?

    Thanks again, HS…

    marking as resolved – we switched to linux and all is good

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘windows server hosted site – image upload issues’ is closed to new replies.