WordPress.org

Support

Support » Installation » Windows Live Writer Won’t Work with WordPress 2.7

Windows Live Writer Won’t Work with WordPress 2.7

  • I just upgraded to WP 2.7 yesterday. Up until this point, I rarely had trouble posting using Windows Live Writer. However, yesterday I received the following error message right after the upgrade:

    The response to the metaWeblog.newMediaObject method received from the weblog server was invalid:

    Invalid response document returned from XmlRpc server

    I am using WLW 12.0.1366.1026 (and just tried the beta v14 and got the same result). The site hosting my blog is using PHP 5.2.6.

    Any suggestions would be helpful. I’ve tried changing the .htaccess file, modifying the xmlrpc.php file, checked to make sure that the class-IXR.php file is in the wp-includes directory, checked case of filenames. So far nothing has worked. Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Did I mention I have a number of posts in WLW that need to be posted ASAP and this error is preventing that? This is a major issue.

    I see from googling this error that this has occurred with previous versions of WordPress and Windows Live Writer. I’ve tried deactivating all the plugins and using the default WP theme, and still get the same error.

    Please help!

    Can’t really help you except to say that Live writer works for me after the upgrade to 2.7. I’m using version 12.0.1370.325, I’m not sure how to upgrade live writer, I think it’s an optional thing in Windows Update.

    It seems to be a problem with multiple embedded images in Windows Live Writer. Text-only posts seem to work just fine. Text + one image posts also upload, although the image filenames get changed (unlike previous versions). So far, I have not been able to upload posts with text + multiple images. I still get the “Invalid response document returned from XmlRpc server” error.

    So based on these results, I’d say there appears to be a problem using Windows Live Writer to upload posts with multiple images to WordPress 2.7.

    I got “Invalid response document returned from XmlRpc server” error too.
    I could successfully add my wordpress blog account in Live Writer, but when I open my old post, the above error occurs. I think it might be a problem of WP 2.7, because everything was OK when I use WP 2.6.5, and my Live Writer version is 12.0.1073.325.

    You need to enable “XML-RPC” in the Write settings. It’s disabled by default.

    Yes, I enable XML-RPC settings, it works fine in v2.6.5, but not 2.7

    🙁 me too

    I am having the same issue…please help!

    I got the same problem. What I did I thought it might be a problem with php file upload limits so I simply modify the php.ini with bigger number and again the same problem. I am talking about my own blog (www.nirjhar.com). Then what did simply setup in my wordpress.com accunt in Live Writer and post the same thing and there is no problem. So that I can tell that only WordPress Stand Alone (no MU) has the problem. Please see my wordpress.com account (http://lrnirjhar.wordpress.com). you’ll find my post is perfect there.

    Regards,
    Nirjhar

    Hye Guys,
    I just got one solution for this issue. Looks like xmlRpc got some issue with different type of file processing. What I did I make all the images into JPG. Now I can post images.. wow. 🙂 Try this hack.

    Regards,
    Nirjhar
    http://www.nirjhar.com

    Just got another effective cause.. here it is

    http://www.ningzhang.org/ <<see and execute..

    Regards,
    Nirjhar

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Windows Live Writer Won’t Work with WordPress 2.7’ is closed to new replies.