Support » How-To and Troubleshooting » Windows Live Writer issue and WordPress 2.6x

Windows Live Writer issue and WordPress 2.6x

  • Hi, Im having a problem, I use Windows Live Writer to Blog WordPress with the Latest version, I moved the Blog to my server, since it was at a free host working great but I moved to my domain, but now everytime I or the staff blogs, Instead of the Blog page showing a Proper blog, it then looks like HTML Blogged.

    Why is this happening?

    Here’s a sample:


    I backed up my old posts, I reinstalled WP 3 times and im getting tired doing this..

    Please help me with this 0=)


Viewing 15 replies - 1 through 15 (of 31 total)
  • An Updated URL:


    please any1?

    Too high security settings at your web host could cause html tags to be stripped.

    so what do I do about this?

    Contact your web host.

    I’m having the exact same problem with 2.6.2. I’ve tried it with Live Writer, ScribeFire and Ecto. Any pointers on the security settings?

    Any feedback on this?
    I’ve contacted my webhost about it and they said that is not the problem.

    Hepl please?

    What does a sample of the code look like before posting and what does it look like after posting?

    I’m really no expert on server stuff, but if your web host is using something like mod_security, it may be preventing you from posting code. Are they using it?

    Also, do not use the visual editor if you are adding your own code and do not switch back and forth between the visual and html editors. Doing so will just mangle your code.

    In my particular case, mod_security is not being used (just confirmed it with my host). I tried all ways, visual editor, source code (one at a time). Not working.
    Code looks fine in WLW at the time of posting, but when cheking on my blog, you can see all the HTML (sortof) like :

    strongThis is a sample sentence/strong
    pThis is another sentence/p
    Just like that

    Same Windows Live Writer is working fine with a test account I created on a Free Web Hosting site. But in my own site (new) there’s no way 🙁

    It could be some CHMOD on some directory or something? (sorry, I’m just clueless and very frustrated 🙁 )

    Try temporarily disabling all plugins and see if the problem continues.

    Thanks for your reply,
    Done that too 🙁 Also, changed templates, etc
    By the way, I just installed ScribeFire, and the same thing is happenning. Very strange.

    One other thing to try:

    Go to Dashboard -> Users -> Your Profile and then deselect Use the visual editor when writing.

    Tried that too, no change. Been lurking Google, and found out some other people having the same issue, with other publishers to, like Blogjet.
    One of them said uninstalling Office 2007 did the trick, but I don’t see any connection with that?

    Any feedback on this or how can I fix it? 🙂


    I just found that is was libxml2-2.7.1-1.fc9 on my server that was causing the problem.

    I down-graded to 2-2.6.32-1.fc9 and I was able to publish with WLW again.



    kim-_nz, thanks for that tip. Where did you find that file on your server, and how does one go about downgrading? I have excatly the problem you are describing, I too thought at first it was WLW and thne also thought it was something specific to WP 2.6.2, because on several blogs that have not yet been upgraded to.6.2 the problem did not appear.

    For those who made a lot of helpful suggestion re. HTML and the Visual editor, this is a weird problem where WordPress displays _partial_ HTML instead of th desired human readble form. In other words, a paragraph which should read “This is my paragraph” and which of course in HTML shows “<p>This is my patagrah … instead displays as ” p>This is my paragraoh … (note the leading ‘<‘ character is stripped of, breaking the code.

    It’s been really, really frustrating the past few day sas every single blog post has to be hand edited, character by character in the HTML editor to put the borked code back into readable format.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Windows Live Writer issue and WordPress 2.6x’ is closed to new replies.
Skip to toolbar