Windows Live Writer and 2.7 error (7 posts)

  1. eltardo
    Posted 6 years ago #

    Ok, first off, my blog is not safe for work so if you're at work, easily offended or what not.. don't go there.

    I was using WordPress 2.51 with Live Writer and all was fine. I post images and what not all the time. I recently upgraded to 2.7 and since then, posting of images doesn't work.

    Yes, I am aware that xmlrpc is shut off by default as us atom btu I know to go into writing... click those on.. save. Still doesn't work. I went into misc and made sure the link to uploads was correct, it is.

    I tried posting... I get these weird figures... here is a copy/paste of how it came out on my site. I have of course since removed this post.


    pSo today I took a up to date pic of my office for those that are nosey and into pix of other people’s computer set ups etc. Most likely guys. =)/p pa href="http://eltardo.com/wp-content/uploads/2008/12/office3.jpg"img title="office" style="border-right: 0px; border-top: 0px; display: inline; border-left: 0px; border-bottom: 0px" height="303" alt="office" src="http://eltardo.com/wp-content/uploads/2008/12/office-thumb3.jpg" width="399" border="0" //a/p


    Notice the p at the start? I didn't type that. Also, I didn't type the /p or the following p etc. Basically, it's not including the < > in the coding anywhere so the code is breaking.

    I'd have thought in testing 2.7, someone would have attempted to use Live Writer.. heh. I know it's not a live writer issue, as it has worked time and time again prior to this new version.

    I spoke with friends that upgraded, they have the exact same error. Thus, wordpress seems to be hooped at the moment.

    I think I had earlier read that it's not uploading images... but it is. if you were to check the links I have above, you'd see the images are indeed there. But the html is broken, it's removing the code < and > throughout the post, thus breaking it.

    Anyone know how to solve this?

  2. eltardo
    Posted 6 years ago #

    I found this on another site.... this is something to copy/paste to your host if you don't run your own box.

    The fix for cPanel servers is to create a file called
    all_php5 under /var/cpanel/easy/apache/rawopts/ and add the following
    two lines then recompile Apache:


    For those who are not using cPanel but instead manually compile PHP,
    the fix is to add the following line after the other ./configuration
    options then build as usual:

    --with-expat=builtin --with-libexpat-dir=/usr/lib

  3. eltardo
    Posted 6 years ago #

    ok.. here is how to fix it. i asked my tech at Phat Servers (HIGHLY suggest them by the way)

    I was told:

    Had to use the libxml2 version that's in freebsd ports.

    Looks like the 2.7.x versions have the bug.

    libxml2 Version => 2.6.32

  4. The IceMan
    Posted 6 years ago #

    i have the same problem,
    but i host my blog on some else server

    what can i do to fix the problem ?

  5. hersheybrown
    Posted 6 years ago #

    I really need help with this issue. I am no where near a network admin but I administer my own blog. I can not seem to post images with live writer, it just stopped working about 2 weeks ago. Please help thanks

    Jai's Daddy

  6. Unfortunately, this is not a WordPress bug, it's a bug in one of the libraries PHP uses. WordPress can't fix it. Your host has to fix it.

    More info here:

  7. mackaaij
    Posted 6 years ago #

    I'll contact my webhost to update the library but this plugin of Joseph works:
    (the manual fix to comment out didn't work for me)

Topic Closed

This topic has been closed to new replies.

About this Topic