Will not post after auto save (8 posts)

  1. mlfelton
    Posted 9 years ago #

    Hi, I've upgraded recently (missed the last 2, so I did them today) and now when I am typing the post after it automatically saves the post, I go to publish it and I get a page that says "Are you sure you want to edit this post: ""?" with a text link for No and a button for Yes.

    An image of the error page can be seen here

    I have clicking on each option, but no matter what I do my post is gone.

    If I click Yes, then it says my post is saved and gives the option to "view post" but it never publishes and doesn't show up in the master list of posts.

    If I click No, it takes me back to a blank post page and there is no draft of my original post anywhere.

    I have also tried saving the post first, but the same thing happens.

    The only way I can get it to post is to copy the whole thing, go back to a fresh write post page, paste it in and publish it before the autosave saves it.

    Is anyone else having this problem? Can anyone help?

  2. syncbox
    Posted 9 years ago #

    yes, I am seeing that, too. Mine causes the post to be added again, so creating duplicate posts (the post plug is different). I am seeing issues with adding custom fields, too... and sometimes, a published post is set to private.

    I am not doing that, wp is. and it all relates to this new "are you sure" page.

    How can someone turn OFF auto save?

  3. syncbox
    Posted 9 years ago #

    I've figured out that when using Save and Continue Editing or Save after adding a custom field, clicking NO to the "Are you sure..." page actually DOES add the field and keeps things from messing up... but I'd like to be able to figure out why this is happening and WHY the solution is so COUNTER-INTUITIVE.

    Or, how can I find that bit and change the buttons (no and yes) to reversed so at least I am clicking YES when I mean yes.

  4. mlfelton
    Posted 9 years ago #

    any new ideas on this one? It's still happening for me. I've taken to writing my in Notepad and then copying them, and posting them really quickly before the Auto Save kicks in. That sort of defeats the whole purpose of having an online "Write a Post" page, don't ya think?

  5. terrih18
    Posted 9 years ago #

    Try this quick fix my friend found.

    Go to wp-includes/autosave-js.php.

    Find the line:

    <?php echo apply_filters('autosave_interval', '120'); ?>);

    and replace with:

    <?php echo apply_filters('autosave_interval', '1200'); ?>);

    Basically it means that WP is now waiting 1200 seconds before autosaving (so 20 mins, rather than 2). You can up that if you want, or lower it. It is, as I said, a quick fix, as it doesn't disable the autosave, but it gives you a little more time to get a post written and published before autosave kicks in.

  6. Michael Bishop

    Posted 9 years ago #

    I've also experienced this bug, and opened a ticket.

  7. If the autosave doesn't actually complete, as in you don't get the response back from the server, but the save occurred on the server anyway, then you won't get the new nonce value updated on the form, and this will cause it to give you that are you sure message when you go to post.

    So I'd say that the problem is that the server is slow or has not responded by the time you hit the publish button. Or something else is wrong somewhere that's preventing the autosave from working.

  8. colleenc
    Posted 8 years ago #

    I have the same issue as of yesterday in version 2.2.1 and I've been looking all over the forums here for a fix.

    As of last night, when I hit save, save & keep editing, or publish, I am taking to post.php, but despite the URL being post.php, I'm at the main page of my blog. The auto save seems to be locking up / not working. I have a post right now that's been sitting for 10 minutes and the autosave is stuck on "Saving Draft..." Another new post hasn't autosaved at all, but I get the above error when I attempt to save or publish it.

    I attempted to edit the time on my autosave file, my version doesn't have that bit of code. This worked perfectly until last night - no new plugins, files, etc. I simply blogged, and then tried to blog again 20 minutes later and found that I couldn't any longer.


Topic Closed

This topic has been closed to new replies.

About this Topic