Support » Plugin: Column-Matic » Will not float:none or clear:both in TwentyTwelve Theme

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Baden

    (@baden03)

    Most excellent question! Very clear, included a link and everything.
    So here’s the deal:
    By default there are two attributes that are automatically assigned values if you do not overwrite them:

    'float' => 'left',
    'display' => 'inline'

    so, what you will want to do is the following:
    1. in your shortcode, always assign the float attributes with a blank value, like-a so:

    [column class="post_column_1" float=""]bla bla bla[/column]
    [column class="post_column_2" float=""]bla bla bla[/column]
    [end_columns]

    2. In your responsive css, you would define .post_column_1, .post_column_2 to float: left or float: none as needed.

    Get it? Good! Please let us know of your trumpeting success with this… so we may uncross our fingers, unpress our thumbs.

    To the Disco!

    Well I gave that a shot, and still it’s not complying with my most polite request.

    Short code:

    [column class="column_one" float=""]Yada yada, spiffy logo image[/column]
    
    [column class="column_two" float=""]Yippy Skippy another logo image[/column]
    [end_columns]

    CSS Media query:

    @media screen and (min-width: 400px) {
    	.column_left, .column_middle, .column_right, .column_one, .column_two, .column_twothird {
    		float:none!important;
    		max-width:95%;
    		margin:0 auto;
    		clear:both!important;
    	}

    Regular CSS:

    .column_left, .column_one {
    	margin-left:0;
    	float:left;
    }
    .column_right, .column_two {
    	margin-right:0;
    	margin-left:2.127659574468%;
    	float:right!important;
    }

    I’m stumped. What say you, Oh Column-Matic god?

    Plugin Author Baden

    (@baden03)

    Hmmm… something is truly wonky. Must be an easy fix we can not see form here.
    Please shoot us an email at: info [at] twinpictures [dot] de and reference this thread. We will get you squared a way! Wocka-wocka.

    Plugin Author Baden

    (@baden03)

    hey, try this: Put a space as the value of float like so:

    [column class="column_one" float=" "]Yada yada, spiffy logo image[/column]
    
    [column class="column_two" float=" "]Yippy Skippy another logo image[/column]
    [end_columns]

    Here is a demo of it working: http://spacedonkey.de/762/column-matic-responsive-test/

    Plugin Author Baden

    (@baden03)

    and in other news… version 1.1 is out, so you can insert the css in it’s own special options page! giggity-giggity.

    Baden my buddy, it’s still not working! I added the spaces, I updated the plugin, put in the custom code into the new options page. Still no floating or clearing.

    http://truenorthe.com

    Plugin Author Baden

    (@baden03)

    This ends now. Please contact support [ at ] twinpictures [ dot ] de and reference this thread. We’ll ask you to set up a temp admin account and we’ll get you squared away, and explain the problem.

    Emailed.

    Plugin Author Baden

    (@baden03)

    Although you had Column-Matic installed, it seems the issue was a conflict with another column plugin: WP Post Columns that was installed.

    Issue Resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Will not float:none or clear:both in TwentyTwelve Theme’ is closed to new replies.