WordPress.org

Support

Support » Plugins and Hacks » Will not connect to MaxCDN

Will not connect to MaxCDN

  • I have updated to the latest W3

    It will not connect to MaxCDN

    I have created an API application on the MaxCDN side, I have provided the Secret and Key and added CNAMEs

    However now that the CNAMES are propagating it seems the problem lies somewhere else.

    I have ALIAS set as the name of the MaxCDN API application, but whenever I test connectivity I get

    Error: Failed with error code 401. Please check your alias, consumer key, and private key.

    Latest WordPress, Latest W3 Total Cache.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 16 through 30 (of 31 total)
  • Plugin Author Frederick Townes

    @fredericktownes

    Sounds about right.

    This is pretty much what I said above, only that spot is the CSS CDN and it means that the url will be an external url.

    Is the new expectation to be that the long url of an external source to be the url of the CSS?

    This wasn’t the case before, why is it the new method?

    I don’t know what a “long url” is and MaxCDN has their old MaxCDN, their new MaxCDN, and their NetDNA pages so the particular version used needs to be specified when discussing MaxCDN.

    What a disaster! 7 hours in and I almost have this upgrade working.

    1 – Enable MaxCDN within the W3 Total Cache plugin.

    2 – Click the “I have MaxCDN’ button from within W3 Total Cache to generate your API keys. (API Consumer Key and Consumer Secret). Once those two keys are created, copy and paste them into the W3 Total Cache plugin.

    3 – Find your ‘Alias’ … In MaxCDN, at the very top of the page, you will see icons for ‘Dashboard’, ‘Zones’, Report’, ‘Account’. Click on ACCOUNT. Here you will find your alias. Copy and paste that alias into the ‘alias’ field within your plugin.

    3 – “Replace site’s hostname with:” … the first site should be the LONG URL provided by MaxCDN. Subsequent names can be the CNAME you generated.

    4 – Make sure your IP is whitelisted.

    I tested the CDN using this method and it works.

    I do this and the “Testing” status hangs. No response.

    I’m assuming a “Long URL” is for me brandon001.recordingreviewc.netdna-cdn.com

    Branddon

    @brandondrury,

    Forget about “Alias: ” and “Test NetDNA/MAXCDN” Button, it’s show error, i left empty this field, my CDN properly working without any trouble.

    I followed all of the steps mentioned by epeolatry and still received “Error: Failed with error code 401…”.

    When I checked my site, however, the CDN is implemented and it’s working. I think the issue is with the Test button.

    W3 Total Cache says the CDN is enabled with MaxCDN, but not a single element in WordPress points to my CDN article.

    @ahmedeqbal, I’ll try ditching the Alias and see if that helps. Thanks!

    The above methods are perfectly working fine.

    Contact me anyone who need my assistance, i will be able to help you out for no cost/free service.

    Gtalk: connect [at] signageinfo.com

    Regards
    SignageInfo

    So for now use your “temporary url” from MaxCDN/NetDNA, it will be a large url like “zonename.alias.maxcdn-cdn.com” or “zonename.alias.netdna-cdn.com“. And then CDN will work with W3 Total Cache.

    I have made a blog post with detail instruction and graphics at my blog Asif.im

    My guess would be that MaxCDN/NetDNA is not exposing the custom Cnames in the API or W3TC is unable to search them for some reason.

    I suspect we will need to either get NetDNA to support that in the API or get Frederick to update W3TC to add a field for MaxCDN/NetDNA temporary URL to use that for the API communications

    even though i’m getting zone not found, the cdn is still working correctly, i just dont have purge support for assets within w3tc

    I ended up getting CDN to work, but it will not pass the test. It just sits and hangs.

    Brandon

    I just deleted the bucket in maxcnd created an new one with the same allias and followed the above mentioned tip to ignore the test.

    CDN is working with custom cname as normal. I guess some problem with the purging of the old stuff.

    Hope this helps

    @nalafod,

    yeah something like that, but i think, you need to figure it out manually by using MaxCDN/NetDNA Control Panel,

    Pull Zones -> Mange Cache

    Version 0.9.2.8 released few hours ago. Now custom hostname works perfectly. Just the test button still does not work.

    Not only the test button but also the purge CDN function is not working if using custom hostname.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘Will not connect to MaxCDN’ is closed to new replies.