WordPress.org

Support

Support » Plugins and Hacks » Will not connect to MaxCDN

Will not connect to MaxCDN

  • I have updated to the latest W3

    It will not connect to MaxCDN

    I have created an API application on the MaxCDN side, I have provided the Secret and Key and added CNAMEs

    However now that the CNAMES are propagating it seems the problem lies somewhere else.

    I have ALIAS set as the name of the MaxCDN API application, but whenever I test connectivity I get

    Error: Failed with error code 401. Please check your alias, consumer key, and private key.

    Latest WordPress, Latest W3 Total Cache.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 31 total)
  • nemoprofeta
    Participant

    @nemoprofeta

    I get the same error. How can we use MAXCDN?

    Just to update, MaxCDN’s support responded suggesting I whitelist my IP.

    I already have a whitelisted IP so that isn’t the issue in this case, this was previously working and now will not connect.

    Same issue. I’m clueless as to what the ALIAS has to be. This field didn’t exist in the previous version, nor does it exists on MaxCDN.

    I managed to get it working. Sort of.

    I entered the alias value as the name of my zone/companyid. In my case, they’re both the same so I’m not sure which it is exactly.

    Unfortunately, I can’t use my custom CNAME’d domain as the hostname. I had to use the default one MaxCDN gives you.

    I entered my Zone name as ALIAS and get

    Error: No zones matching custom domain.

    I’ve got my Alias as Zone Name

    I set my first custom domain from being

    cdn.goldenplec.com to goldenplec.goldenplec.netdna-cdn.com which is where my CNAMES point to. It now passes

    I’ve left the other three as cdn1 cdn2 and cdn3

    I’m unsure why this has now passed. Is it working propely or not?

    In my case, both the name of the zone and the companyid is, say, ‘example’. So my default hostname is

    `example.example.netdna-cdn.com

    So I’ve entered ‘example’ as the Alias and in the ‘Replace site’s hostname with’ field, I’ve entered ‘example.example.netdna-cdn.com’.

    So this works for me, but I can’t use my custom ‘cdn.example.com’ domain yet. Let’s hope the plugin author responds.

    If you add CNAMES you can use your custom CNAME for JS in the head and JS in the body etc. so currently I have

    LONG MAXCDN URL -> CSS
    CNAME1 -> JS in head
    CNAME2 -> JS after <body>
    CNAME3 -> JS before </body>

    So now I just need to get my CSS loading from a CNAME and it’s all working. Author response would be great

    Arsie Organo
    Member

    @eyesfortech

    I just spoke with the MaxCDN support by the name of Ivan D. We both tried to troubleshoot the problem and here is what is his recommendations:

    1. Don’t fill the Alias, Consumer Key, and Consumer Secret. The API is intended only for remote purging where you can do it by going to your MAXCDN account.
    2. Don’t change your custom CNAME, leave them as is. To verify that it is still working, check your site if the images, etc are still hosted by your custom CNAME.
    3. They will talk to W3TC dev about the API he added to the latest version of W3TC because they (MAXCDN) were not informed of these changes.

    I hope the author of W3TC would respond.

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    We already work closely with MaxCDN. Will figure out where the confusion lies.

    Arsie Organo
    Member

    @eyesfortech

    Cool Fred! Give us the update as soon as it is clarified.

    Thanks Fred. Appreciate that

    healthable
    Member

    @healthable

    [ Moderator note: de-capped. Please do not use all caps again, it’s considered rude. ]

    this plugin is conflicting with my themes… my old themes uses my new theme footer and retains its layout+color even when i didnt activate it. and my cloudflares redirects to a 404 error page once i click save

    Healthable start your own thread as the above has nothing to do with MaxCDN

    epeolatry
    Member

    @epeolatry

    I think I Have fixed it …

    Note: Not sure if it makes any difference, but I deleted my pull zone and re-created it within MaxCDN.

    1 – Enable MaxCDN within the W3 Total Cache plugin.

    2 – Click the “I have MaxCDN’ button from within W3 Total Cache to generate your API keys. (API Consumer Key and Consumer Secret). Once those two keys are created, copy and paste them into the W3 Total Cache plugin.

    3 – Find your ‘Alias’ … In MaxCDN, at the very top of the page, you will see icons for ‘Dashboard’, ‘Zones’, Report’, ‘Account’. Click on ACCOUNT. Here you will find your alias. Copy and paste that alias into the ‘alias’ field within your plugin.

    3 – “Replace site’s hostname with:” … the first site should be the LONG URL provided by MaxCDN. Subsequent names can be the CNAME you generated.

    4 – Make sure your IP is whitelisted.

    I tested the CDN using this method and it works.

    Let me know how it works out.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Will not connect to MaxCDN’ is closed to new replies.