Support » Plugin: 410 for WordPress » Wildcard option not working

  • My sites were hacked recently, so I was using this plug-in to tell Google to stop trying to find/index all the random pages created. Since individually marking URLs as 410 was causing the table to be huge (18k records and counting), I added wildcard options instead.

    However, the ones I’ve set up using just the first letter of a file/directory are throwing out 404 rather than 410. Example: http://mysite.com/Y* gives me a 404 for any URL I type in that starts with Y that rather than a 410.

    The ones setup with the tail end of the URL seem to working, though. Example: http://mysite.com/*.item gives a 410 regardless of what is in the wildcard spot.

    Only big change I’ve made recently was to add WP Super Cache, but this plug-in is supposed to work with that one.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Samir Shah

    (@solarissmoke)

    Thanks for reporting this. I am a bit busy at the moment but will try and look into this in the next few days.

    Plugin Author Samir Shah

    (@solarissmoke)

    I’m not able to reproduce this issue – adding http://example.com/Y* to the 410 list and then visiting any URL starting with Y gives me a 410. I don’t know why it doesn’t work for you, but would suggest (a) making sure that no other plugins are interfering with how WordPress handles 404s and (b) temporarily disabling the cache to see if that is involved (it shouldn’t, but there might be some issue there).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wildcard option not working’ is closed to new replies.