Wierd stuff is happening from web (4 posts)

  1. TeamEmilie
    Posted 1 year ago #

    So I have just installed MariaDB, Phpadmin and WordPress on my Synology NAS. All totally standard and just typed in what was requested. (user and password for the most)
    I have done none other configuration.

    But now I have 2 major problems

    1 The wordpress site and wp-admin site work fine locally on my LAN with the internal IP adress. But from the WAN site (from the internet) I get the page, but when I try to click anything it tries the local ip adress.
    I searched and replaced my local ip in the wordpress database and replaced with my http://www.xxxyyy.dk domain name. Now all links are working. I dont know if this is the right way to make a locally wordpress run on the internet?

    2. Even before the above change and also after (made no difference) the site is all without CSS or what is used for styling. It is just the text and links. None style what so ever. Is there still something missing since the theme (any theme, have tried a few) does'nt work? If I connect on my LAN site to the site it works fine and have a nice layout.

  2. Mark Senff
    Posted 1 year ago #

    Your URL/site settings are probably not configured properly. It's hard to tell without seeing a link. Any chance you can share the URL to your site?

    Check in your WP admin under Settings -> General what it says under WordPress Address (URL) and Site Address (URL). These need to be the URLs of the site as they should be accessed outside of your LAN (http://www.xxxyyy.dk) and not your IP address.

  3. TeamEmilie
    Posted 1 year ago #

    The WordPress Address (URL) is greyed out and can't be changed.
    The other one I have tried to manually change, but is says that it is not a valid URL. If I change the value for Site address in the database it is okay. But the first one I have not managed to change. I can't share the link right now, as I use the same link for a normalt Windows web server. So i only change the port forwarding when i'm testing.

  4. Mark Senff
    Posted 1 year ago #

    It's likely that the URL is set in the wp-config.php file or perhaps functions.php using lines like these:


    The fact that you can't change it in the admin is why this method shouldn't be used so you should find them and remove them.

    Instead, you should use these:


    This will set those values in the database, and you should remove the lines again once you got things running properly.

Topic Closed

This topic has been closed to new replies.

About this Topic