WordPress.org

Forums

All in One SEO Pack
[resolved] Wierd Sitemap problem (20 posts)

  1. Kramarz
    Member
    Posted 12 months ago #

    Ok, here it is.

    When I update some setting withing sitemap settings and check the sitemap using 'view your sitemap' it shows me sitemap.xml just as it should.
    Now, if I refresh the page sitemap is gone and all I get is 404 from now on.

    Google is also unable to find the sitemap when trying to upload it using webmastertools.

    Any tips? Link in question - http://www.jfsports.ie/sitemap.xml

    https://wordpress.org/plugins/all-in-one-seo-pack/

  2. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    I went to the URL http://www.jfsports.ie/sitemap.xml and I see you are not using All in One SEO Pack to generate your XML Sitemap, you are using the Google XML Sitemap plugin by Arne Brachhold. The sitemap appears to be working fine but if you have issues with it you should post in the support forum for that plugin.

  3. Kramarz
    Member
    Posted 12 months ago #

    That's correct wpsmort.
    But the only reason for that is that I had to turn off broken functionality of AIOS and install separate plugin for that.
    So the issue in question stays related to AIOS, I just couldn't wait any longer, knowing it can take ages to get a hand sometimes :-)

  4. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    The only way we can troubleshoot the issue is if we can see it happening on your site. If you want to enable All in One SEO Pack XML Sitemap and contact me once you've done that.

  5. Kramarz
    Member
    Posted 12 months ago #

    Right,
    I disabled Google XML Sitemap plugi and re-enabled AIOS sitemap...
    Ended up with 500 Internal Server Error, with no access to the website anymore.
    Any advice on that one?

  6. Kramarz
    Member
    Posted 12 months ago #

    ok, nvm found the reason... for whatever reason my .htaccess contents got changed...

  7. Kramarz
    Member
    Posted 12 months ago #

    Anyway, AIOS Sitemap is back in place for you to take a look.

  8. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    I see a 404 error when I go to http://www.jfsports.ie/sitemap.xml which indicates this is an htaccess issue. You'll need to flush your htaccess file and check your Permalink settings.

  9. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    Can you send us your WordPress administrator login so we can take a look. You can use the contact form here to send this to us - http://semperplugins.com/contact/

  10. Kramarz
    Member
    Posted 12 months ago #

    Yea, this is what I mean, when I'll get in the settings, update sitemap and then view your sitemap, I can see it, but only once.
    Permalinks are set to postname, and there's nothing in .htaccess.
    This is how it looks now:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  11. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    Can you send us your WordPress administrator login so we can take a look. You can use the contact form here to send this to us - http://semperplugins.com/contact/

  12. Kramarz
    Member
    Posted 12 months ago #

    Done, thanks.

  13. Kramarz
    Member
    Posted 12 months ago #

    Sorry, forgot to actually include login details... so I have filled another form...

  14. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    You have some custom code in your theme's functions.php that prevents you from updating WordPress, updating any theme and updating any plugin. You'll need to remove that and then update All in One SEO Pack to the latest version and see if this fixes your sitemap issue.

  15. Kramarz
    Member
    Posted 12 months ago #

    Hi wpsmort,
    Plugin updated to latest 2.1.6 version.
    Didn't help, issue still there.

  16. Kramarz
    Member
    Posted 12 months ago #

    Ok, looks like it works now, what did you do? :-)

  17. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Hi Kramarz,

    Your theme contained a function which registered a testimonials post type and then flushes the rewrite rules. This is the incorrect way to implement a custom post type and was affecting our ability to rewrite rules for the XML Sitemap. We've commented out the offending code from your functions.php

  18. Kramarz
    Member
    Posted 12 months ago #

    Was it this part that you commented out?
    // flush_rewrite_rules();
    Need to show it to theme developers.

  19. wpsmort
    Support Manager at Semper Fi
    Posted 12 months ago #

    Yes, that is correct.

  20. Kramarz
    Member
    Posted 12 months ago #

    Ok, thanks for taking your time and checking that for me :-)
    Hope nothing gets broken by commenting that out ;-)

    Kind Regards

Reply

You must log in to post.

About this Plugin

  • All in One SEO Pack
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.