WordPress.org

Support

Support » How-To and Troubleshooting » Wierd date in my RSS feed

Wierd date in my RSS feed

  • My rss feed (feed=rss2) has a wierd pubDate in it. One of the nested pubDates in listed as – but none of my posts are using this date.

    <pubDate>Tue, 30 Nov 1999 00:00:00 +0000</pubDate>

    Why is this happening? How do I make it display the correct date?

    Thanks!
    Erik

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- generator="wordpress/2.2.1" -->
    <rss version="2.0"

    xmlns:content="http://purl.org/rss/1.0/modules/content/"
    `xmlns:wfw=”http://wellformedweb.org/CommentAPI/”
    xmlns:dc=”http://purl.org/dc/elements/1.1/”
    >

    <channel>
    <title>LYBP</title>
    <link>http://www.myblog.com/blog</link&gt;
    <description>My Blog</description>
    <pubDate>Sun, 22 Jul 2007 19:04:41 +0000</pubDate>

    <generator>http://wordpress.org/?v=2.2.1</generator&gt;
    <language>en</language>
    <item>
    <title>New LYBP Blog</title>
    <link>http://www.myblog.com/blog/?p=1</link&gt;
    <comments>http://www.myblog.com/blog/?p=1#comments</comments&gt;

    <pubDate>Tue, 30 Nov 1999 00:00:00 +0000</pubDate>
    <dc:creator>Erik</dc:creator>

    <category><![CDATA[Uncategorized]]></category>

    <guid isPermaLink=”false”></guid>
    <description><![CDATA[Hello, World!`

Viewing 2 replies - 1 through 2 (of 2 total)
  • Try it with a real post (not the default “first post”) and see if you have the same issue.

    An update for anyone else with this problem. It was an issue with the default first post. the post_date_gmt in the database was set to 0000-00-00 00:00:00 – I replaced it with the real timestamp – fixed!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wierd date in my RSS feed’ is closed to new replies.
Skip to toolbar