WordPress.org

Support

Support » Installation » [Resolved] widgets.php Problem

[Resolved] widgets.php Problem

  • notxap
    Member

    @notxap

    After upgrading from WP2.2.3 to 2.6.2 I get the following error at the top of the blog pages both in the site and the admin pages.

    If I replace the file widgets.php in the wp-includes directory with the older widgets.php file from my back-up of the 2.2.3 version the error disappears. Is it ok to do this or should I be using a different solution ?

    Warning: array_keys(): The first argument should be an array in /share/storage/03/no/notxap/wp-includes/widgets.php on line 686

    Warning: Invalid argument supplied for foreach() in /share/storage/03/no/notxap/wp-includes/widgets.php on line 686

Viewing 7 replies - 1 through 7 (of 7 total)
  • notxap
    Member

    @notxap

    If anyone can help I’d be very grateful.

    Gary

    notxap
    Member

    @notxap

    Also get this error

    Warning: Cannot modify header information – headers already sent by (output started at /share/storage/03/no/notxap/wp-includes/widgets.php:686) in /share/storage/03/no/notxap/wp-includes/pluggable.php on line 770

    When changing themes

    notxap
    Member

    @notxap

    Dashboard doesn’t seem to work right either, the panels display “loading..”

    notxap
    Member

    @notxap

    Warning: array_search(): Wrong datatype for second argument in /share/storage/03/no/notxap/wp-admin/includes/widgets.php on line 85

    Obviously putting an old version of widgets.php in the wp-includes was the wrong thing to do…

    notxap
    Member

    @notxap

    When I try to activate plugins I get the following error..

    Warning: array_keys(): The first argument should be an array in /share/storage/03/no/notxap/wp-includes/widgets.php on line 686

    Warning: Invalid argument supplied for foreach() in /share/storage/03/no/notxap/wp-includes/widgets.php on line 686

    Warning: Cannot modify header information – headers already sent by (output started at /share/storage/03/no/notxap/wp-includes/widgets.php:686) in /share/storage/03/no/notxap/wp-includes/pluggable.php on line 770

    Warning: Cannot modify header information – headers already sent by (output started at /share/storage/03/no/notxap/wp-includes/widgets.php:686) in /share/storage/03/no/notxap/wp-includes/pluggable.php on line 770

    Warning: Cannot modify header information – headers already sent by (output started at /share/storage/03/no/notxap/wp-includes/widgets.php:686) in /share/storage/03/no/notxap/wp-includes/pluggable.php on line 770

    notxap
    Member

    @notxap

    Might be fixed. Seen this on another post and tried it…

    Look at your wp-config.php file. If you see this line, remove it:

    define(‘DB_CHARSET’, ‘utf8’);

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/gasyoun/public_html/wp-includes/widgets.php on line 686

    Warning: Invalid argument supplied for foreach() in /home/gasyoun/public_html/wp-includes/widgets.php on line 686

    Same error, removing define(‘DB_CHARSET’, ‘utf8’); did not helped
    No way to upgrade to 2.6.2 from 2.3 versions

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] widgets.php Problem’ is closed to new replies.