WordPress.org

Support

Support » Plugins and Hacks » Widgets won’t configure

Widgets won’t configure

  • I have installed the sidebar widgets, and they were working just fine. I added some text widgets, and those worked fine, until I used a UL tag to indent the content some to fit better on my theme. Since then I have been unable to confiugure ANY of my widgets. That is, the little box on the right of each widget that you click to bring up more details about the content of that widget is not working. Nothing happens.

    I have tried deletinig the text widgets, de-activating and re-activating the plugin, i even re-installed the widgets via ftp to see if the overwrite would help. Nothing – it is as if I hadn’t done anything. In short, I would like to get the ability to edit my widgets back, but they seem stuck.

    The drag and drop functionality works fine – it is just the individual ones remain uneditable.

Viewing 15 replies - 16 through 30 (of 44 total)
  • Same here. I can drag widgets to/from sidebar and rearrange them, but that little button that opens the popup windows does not work. Hence, I cannot configure my widgets.

    It used to be possible – but it isn’t anymore. No WP upgrade.

    Hmm, I have inserted text and hyperlinks (with images) in the text widgets…

    Eh, this is embarrassing but…

    restoring wordpress/wp-includes/widgets.php to original state solved my problem. I had been messing with that script in order to make Gengo translate the widget headers and in order to replace the “Search” -text with an image. I managed to change too many places (one too many, actually), and broke the widget editing. A few rollbacks, and now I have no problems anymore (but I still have the new features I added).

    I also detected that the “js-things don’t work” situation was happening in this widgets-admin panel ONLY. Hence, this script was the cause. No, it was not a file permission issue. It was code problem. It did not affect only the widget editing code, but it also disabled at least Admin Dropdown Menus js-code.

    I would recommend a restore of wp-includes/widgets.php as a general solution.

    Does this work for you?

    Same problem here. Thing is, it only affects one of the two blogs I installed ON THE SAME DAY!!

    Can’t configure mine, either. I can move them, but when I click on the configure icon, nothing happens.

    Tried switching themes to default (figured if any would work, it would) – but no joy.

    🙁

    Hey, fixed it. In my case, it turns out that deactivating the “Buy Me A Beer” plugin corrected the problem.

    I’ll pass that on to the developer.

    I just had the same problem. Deactivate any plugins that you are not using or really don’t need. It worked for me.

    Hello,

    Suddenly I can’t configure the sidebar widgets of all my WordPress blogs and websites, any idea on how to fix this?

    I tried to deactivate all the plugins but nothing changed.

    I also tried to upgrade to wordpress 2.3 but it didn’t help.

    I’ve been searching among other topics in this forum but I didnt’t find nothing that could help.

    Now…considering that I’m not the only one with this problem…and considering that this is a ‘support forum’…please, could anybody from WordPress try to help us?!

    Is there any moderator or senior member that can give us support to solve this problem?

    I really think that WordPress is super so please don’t let us down!

    Any idea? Help? Suggestions?

    kevinboer

    @kevinboer

    Here’s how I was able to get the widgets to behave themselves…

    First, a description of the problem.
    Second, how I solved it. Hope it helps other folks. This forum has been immensely helpful to me, and I’m glad that I can finally return the favor.

    —————————————–
    First, a description of the problem:

    I’m running WordPress 2.1.3 (I haven’t upgraded because of compatibility issues with some of the other widgets I’m running)

    Yesterday, widgets were running fine.

    Suddenly today, widgets were no longer running fine. In particular, as described above, I was getting the following symptoms:

    In Firefox: In Presentation – Sidebar Widgets, the little icon on the right side of each widget — the one you press to configure it — had simply disappeared for all the widgets. No way to configure any of the widgets.

    In Safari: Same as Firefox.

    In IE6: The icon appeared, but only worked sporadically to allow me to configure each widget.

    ————————————–

    Secondly, how I solved it:

    I noticed that I was running an earlier version of the Sidebar Widgets plugin (version 1.0.something).

    I simply went to http://automattic.com/code/widgets/ and re-installed the Sidebar Widgets plugin for WordPress 2.1.x provided on that page. The version of the Sidebar Widgets plugin appears to be 1.2.1.20070210b

    ——————-

    Further comments:

    a) I believe this fix will only work if you’re also using WordPress 2.1.x.

    b) If you’re using WordPress 2.0.x, it will probably work to re-install the Sidebar Widgets plugin for WordPress 2.0.x, also provided at http://automattic.com/code/widgets/

    c) If you’re using WordPress 2.2 or later, I don’t know what the solution would be, as the Sidebar Widgets plugin is, as I understand it, included in the install.

    I’m having the same issue. The oddest thing is that on my own home server the widget configuration works perfectly, but on the remote server where the official site is it suddenly doesn’t work. I have no idea about what it could be, if not maybe different file permissions for the scripts.

    Same problem for me too — won’t configure. I’ve read all the posts here and in some other threads. I deleted via FTP my old installation of Sidebar Widgets [originally installed back in February but never used until early this week when I discovered the configuration problem]. I downloaded again Sidebar Widgets for WP 2.0, uploaded the newer version and activated it. Same problem. Then I uploaded several newer widget ready themes and tried them — same problem.

    Also the widget list and the sidebar column are not side-by-side — one is above the other. Drag and drop works OK.

    Any ideas?

    I’m frigtened to upgrade to 2.3, as my blog has a very elaborate category/child-category system — and I’ve read 2.3 plays dirty with old categories.

    HELP!!!

    MORE TO MY REPLY OF 2 DAYS AGO, which is just above:

    Since no advice forthcoming about how to get widgets working in 2.0 [busy weekend for everyone, I guess], I bit the bullet and installed 2.3 in a separate folder, with copy of database.

    The installation went OK: I’ve got all the posts and pages from my old installation. Of course, the plug-in are not there, but then they need to be upgraded and installed — I see no problem there.

    HOWEVER: again, the widget page doesn’t work. In this case, I can’t even drag and drop the widgets that comes with 2.3 — I only see a text list of widgets, not appearing in the usual individual boxes.

    HELP!!!

    I’ve been working on this for maybe 15 hours now over the past 3 days.

    Same problem here, I suddenly had this problem on 2.2.3 and couldn’t configure any widgets. I upgrade today to 2.3 and now I can configure all widgets except 2, top commentator widget and picasa widget. All other work fine.

    Would be really great if someone can help. I also disabled all plugins, but no change.

    I’m more the same as you guys, only I am running 2.3.1 with widgets already installed when I installed it, my problem is:

    When I go to the widgets page, I can click on the configure button next to the widget and the configuration box comes up (screen goes light blue at the same time) but when I try to click on any of the configuration boxes the whole thing just disappears again and im left with the widgets screen, tried it in several different internet explorers all with the same results, im suprised there hasnt been anyone who can help here

    Same Problem here – im suprised too that there hasnt been anyone who can help here.

Viewing 15 replies - 16 through 30 (of 44 total)
  • The topic ‘Widgets won’t configure’ is closed to new replies.