WordPress.org

Support

Support » Plugins and Hacks » Widgets won’t configure

Widgets won’t configure

  • I have installed the sidebar widgets, and they were working just fine. I added some text widgets, and those worked fine, until I used a UL tag to indent the content some to fit better on my theme. Since then I have been unable to confiugure ANY of my widgets. That is, the little box on the right of each widget that you click to bring up more details about the content of that widget is not working. Nothing happens.

    I have tried deletinig the text widgets, de-activating and re-activating the plugin, i even re-installed the widgets via ftp to see if the overwrite would help. Nothing – it is as if I hadn’t done anything. In short, I would like to get the ability to edit my widgets back, but they seem stuck.

    The drag and drop functionality works fine – it is just the individual ones remain uneditable.

Viewing 15 replies - 1 through 15 (of 44 total)
  • any ideas? I have not seen anybody have a similar problem, but if anyone could offer a suggestion, I would appreciate it, as I am out of ideas, but I want to keep using widgets…

    I’m having the same problem… tried to change browser, reinstall it, everything… 🙁

    I’m having the same problem, all of a sudden the ability to configure my widgets just stopped. I’ve tried using IE & FireFox. I’ve even re-installed the widgets plugin (and double checked file folder location). Was working fine last week.

    The only thing I did from then until now was activated then de-activated UTW and did the same for useronline & the widget.

    I’m having the same problem. The sidebar arrangement box displays “Default Sidebar” and the widgets are all along the bottom, but I can’t edit the widgets or get them to actually stay in the arrangement box. If anyone knows what’s going on, there are at least four people here who would love to know what’s up.

    Same here. We need help =(

    Widgets would be a good idea but its problems like this that keep me back from relying on them to any degree. I am having the same problem, and it’s a good thing I don’t really need them, cause if I did I would be screwed.

    I am having the same problem – everything was hunky dory until I upgraded to 2.2.1 – and now I can’t do a thing with my widgets – access denied as it were. Anybody go any ideas. I have tried all sorts of things but no luck.

    Can’t configure Widgets?

    Check

    Widgets won’t stay in the box?

    Check

    Sounds like I’m suffering the same problem. I think Shardul may be onto something with the 2.2.1 angle. I have another site running 2.1.3 with the same Widgets and I’m not having problems with it.

    Any ideas?

    I am also facing the same problem here. I can’t configure my text and rss widgets. Stuck! Any solution?

    I’m new to the WP support forums, but I’m wondering if there’s a way to elevate this thread to catch the eye of a mod or senior member who might be able to assist. Obviously the eight of us have yet to find a solution. How do we activate the Bat Signal?

    Am having the same problem with Widgets since upgrading to 2.2.1 Can’t activate the plugin because I get a “fatal error” when I try and am unable to access my widgets to do anything with my sidebar content. Is there a fix for this or are we having to just suck it up and left hanging with half working themes and blogs?

    I am having a similar problem. Sidebar option doesn’t show up in presentations and when I try deactivate/activate the widgets plugin it says ‘fatal error’.

    Quite annoying. Hope the powers that be take a look at this sometime soon.

    I have been able to get around this problem in another way thanks to the advice of Sadish, who is the creator of the MistyLook theme that I use on my site, and his buddy Kasia. You can see our conversation here: http://forums.wpthemes.info/comments.php?DiscussionID=607
    The advice that Kasia gave me regarding manually configuring the side bar in the sidebar.php file worked and that is how I reconfigured my sidebar in the end. If you are using a theme other than MistyLook, perhaps it would be wise to ask your theme’s creator about this – I’m a relative newbie to all this.

    And if you do try the manual option, which isn’t too difficult once you get the hang of it, my advice would be to backup your original sidebar.php file before you start in case everything goes pear-shaped and you need to reinstall the original to start again.

    My site is http://www.kiwicelt.com and all the sidebar widgets above Recent Posts were installed manually. Good luck… I do hope a real expert chimes in about this issue at some stage. I would personally prefer to configure my sidebar via the conventional route and hope it fixes itself at some stage – perhaps with the next upgrade of WP. Cheers…

    My widgets worked fine until I upgraded from 2.2.1 to 2.2.2, and now the status bar of the widgets page says Done, but with errors on page. and the ‘configure’ buttons don’t work. They can still be moved around, however.

    Has anyone got a fix for this without manually putting them into sidebar.php?

    Update: an impulse made me double click the status bar, and I found some details about the error:
    Line: 100
    Chare: 4
    Error: 'null' is null or not an object
    Code: 0
    URL: http://www.thecrazyaustralian.com/wp-admin/widgets.php

    I’m another one whose widgets are stuck. Can’t add new ones to the box, can’t edit the ones I have. Any more info on what the problem might be?

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Widgets won’t configure’ is closed to new replies.