Support » Plugin: Widgets Reloaded » Widgets Reloaded: Version 1.0.0

  • Plugin Author Justin Tadlock

    (@greenshady)


    WordPress God

    Quite a bit has changed in this version while a lot of things have stayed the same. You can view the 1.0.0 release post here: https://themehybrid.com/weblog/widgets-reloaded-version-1-0-0

    And, here’s the full change log: https://github.com/justintadlock/widgets-reloaded/blob/master/changelog.md

    PHP 5.3.0+

    Version 1.0.0 requires that you use PHP version 5.3.0+. If you’re unsure what version you’re running, here’s a plugin that will inform you:

    https://wordpress.org/plugins/display-php-version/

    Search Widget

    The search widget was removed in this version simply because it was no different than the current WordPress search widget. You’ll want to use this.

    Calling widgets via the_widget()

    If you’re an advanced user who was calling widgets via PHP code via the_widget(), you’ll want to update your code. The widget class names have been changed to utilize namespacing in PHP 5.3.0+.

    Widget classes are now in the form of Widgets_Reloaded\Widgets\Name. For example, here’s how to display the archives widget via code now:

    
    <?php the_widget( 'Widgets_Reloaded\Widgets\Archives' ); ?>
    
  • You must be logged in to reply to this topic.