Support » Fixing WordPress » Widgets refuse to uncollapse

  • Resolved wrongforum


    Upgraded to 2.8 yesterday, and the first thing I wanted to take a look at was the redesigned widget panel. I am unable to “uncollapse” my live widgets to get at the settings any longer.

    When I click on the downward-facing triangle to the right of the widget title, the page jumps a little but the options do not appear. The error is reproducible on Mac Firefox 3 and Mac Safari 4, and I’ve tried it on both Intel and PPC computers to no avail. I run a lot of extensions in Firefox, but none in Safari 4.

    I’ve also tried clearing the caches for the browsers, turned off Google Gears for the site, and did a re-install of 2.8 using the auto-installer in the dashboard. None worked.

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)


    Having same problem and some widgets are appearing on the site in their html format and I can’t remove either by deleting (because the widget management tool doesn’t work) or by dragging the widget away (drag doesn’t work either).

    I, too, have this problem with 2.8, when my site is viewed in either IE or Firefox:
    * Can’t drag Widgets around.
    * Can’t drop-down Widgets that are on my sidebars.

    Funnily enough, the page scrolls down when I attempt to drop-down a Widget that has (IIRC) a long setting panel–apparently, the Widget IS trying to open, but on some invisible “rendering layer” in the browser.

    I wouldn’t even have noticed had the installation not deactivated my Collapsing Links widget–all others migrated fine (and I’d bet it would, too–it’s pretty darned simple). So I consider this problem as having an installation bug as well: there’s no reason to remove a Widget; just let it mis-render if it somehow is made obsolete by the update, and hopefully the widget author will update it (and I can then “fix” the problem with a mouse click).

    For the record, I use a mix of hard-coded sidebar elements (in the sidebar.php file itself) and widgets managed through the WP Admin tools. It’s the only way that I can control the Meta info (I’d prefer not to WP brand my whole site, thanks) and use two instances of WP-Cumulus (one for Categories, one for Tags).

    I’ve otherwise been delighted with WP–after all, this is my first “bug report.” Bravo!

    …But, like, please fix this fast. I use my Links a LOT, and now I have to hand-code them into the sidebar.php file, which will be quite ugly (for one, it’s LONG). Thanks!

    try deactivating all your plugins (do take note which plugins you have activated). Then check if your widgets are working, if they are then re-active your plugin one by one until you found the culprit. It works for me!

    My 2.8 install results:

    All drop down menus are affected in the admin mode. The apparent bug disables the mouse over drop down function for all menus (dashboard, settings, etc. Simultaneous access to two or more menus is disabled. Menus cannot be dragged or dropped. This includes the widgets. Activating/deactivating plugins does not address the underlying issue on my install. Yikes!

    Any ideas?

    Ditto for me. I have already posted to another problem with Error 500 Internal Server Error messages whenever moving around wp-admin. On this issue, I cannot activate the dropdowns by clicking on them.

    There do seem to be a large number of problems with this latest version and I’m beginning to regret upgrading as this version is currently not workable. I may have to revert back to 2.7.1 until these bugs are fixed.

    *doh* Deactivated WP Widget Cache and all is fine. (Duh.)

    Looks like it was a plugin incompatibility. Not sure which one, because I had a few that got upgraded today (it was between Advertising Manager, All in one SEO, or Intense Debate).

    Next time I have weirdness during an upgrade I’ll be sure to turn off plugins if I’m having issues.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Widgets refuse to uncollapse’ is closed to new replies.