WordPress.org

Forums

Sublime Press
Widgets problem (17 posts)

  1. MW2014
    Member
    Posted 1 year ago #

    Hello !

    I have just installed the Sublime press theme by Amplifiii. It says that it works with widgets but the widgets won't show on my website.

    What should i do ?

    Thank you for your help.

    http://www.youmebrooklyn.com

  2. salsaturation
    Member
    Posted 1 year ago #

    You need to select the correct template when editing. 'Page-With-Sidebar' under templates part of the editor page

  3. MW2014
    Member
    Posted 1 year ago #

    Thank you for your answer.

    The thing is that i didn't edit anything. I just went to widgets and chose them. They just won't show.

    What should i edit ?

  4. salsaturation
    Member
    Posted 1 year ago #

    You need to edit each page and change the template otherwise it just uses the default template

  5. MW2014
    Member
    Posted 1 year ago #

    I changed the template of all the pages. Still not working.

  6. MW2014
    Member
    Posted 1 year ago #

    I think i didn't do the right thing and i just don't know how and what to edit.

  7. salsaturation
    Member
    Posted 1 year ago #

    for example lets say you have a page called contact you need to go to the backend Pages > All Pages > Contact - click edit then on the right hand side there is a 'template' section (if you cant see it have a look at 'Screen Options' on the top right handside to ensure it is switched on) select the 'Page-With-Sidebar' template... Is this what you did?

  8. MW2014
    Member
    Posted 1 year ago #

    Oh thank you so much ! I know how it works now. But the thing is that i can't find the "home" page. Therefore i can't add a sidebar on the homepage, can I ?

  9. salsaturation
    Member
    Posted 1 year ago #

    Create a page called home and assign the sidebar

    Then go to Settings > Reading and assign the page you created as the homepage

  10. MW2014
    Member
    Posted 1 year ago #

    I did everything right this time but the widgets won't show if the page is the one hosting the posts. They do show when it's a simple page though.

  11. salsaturation
    Member
    Posted 1 year ago #

    In this case you will need to create a Child_Themes and add the sidebar code to the index.php file. Please try this and let me know how you get on

  12. MW2014
    Member
    Posted 1 year ago #

    Can you please tell me which index.php i have to edit ? There are 3 files with the same name. Shoudl i edit the one in the content directory ?

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    You should only ever edit files in your child theme's folder.

  14. MW2014
    Member
    Posted 1 year ago #

    It works now but look at what it does : http://youmebrooklyn.com/.

    Maybe i should try to put everything in the footer ?

  15. MW2014
    Member
    Posted 1 year ago #

    Now it works perfectly on the footer but it was a mistake. I copied & pasted the index.php file in the sublime press directory before doing it in the sublime press child directory.

  16. MW2014
    Member
    Posted 1 year ago #

    Found out it only works if i add an url to one of the social networks' button. But there is something wrong with the search button. Can anyone tell me how to fix this ? Thank you !

  17. salsaturation
    Member
    Posted 1 year ago #

    Can you elaborate on your issue as the search works as expected for me

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic