Support » Plugins » Widgets Plugin – Scriptaculous broken!

  • Resolved Karrde


    Hi all,

    Just been playing with the new Widgets plugin, as a precurser to modifying my theme to support it. However, I can’t get the plugin to work properly. I’ve installed it as per the included instructions but when I choose a theme that’s compatible with widgets (default, or classic for example), then go to the newly appeared Sidebar Widgets page, the scriptaculous functions that would make the page interactive are not working. I’ve ensured the scriptaculous scripts are in the right place, and I’ve also tried putting them in other places to see if that’ll fix it, but no joy.

    From my quick examination of the widgets plugin and the source code of the Sidebar Widgets page, it seems to me that the header code – sidebar_admin_head() – isn’t being run for the Sidebar Widgets page – I can’t find any of the code that should be visible in the page source if it were running.

    Any help would be appreciated. I know this probably isn’t the best place to post support queries for the plugin, but I can’t find anywhere on automattic that I could post to either.

    – Karrde

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same problem and I’ve tried it on 2 seperate WP boxes. Anxious to read a solution.

    First, I’m glad I found this post. No, sorry I don’t have an answer. I’m actually having the same exact problem. I was worried that it was something with my browser or something that my computer was blocking so I created an account on the sidebar widgets plugin worked on there.

    I thought I was the only one having this problem. I emailed matt “photo matt” so hopefully I get a response. I did see one forum where somebody was having a problem. The only response to that was. Yeah, I have fixed the problem. Well obviously he didn’t fix the problem. If anybody finds the answer post it.

    I’ve been looking for the answer to this all weekend. The plugin looks great. If it would work. Thanks


    In another thread karrde posted a fix for this. I haven’t tested myself yet, so no idea if it really works, but it might be a start and it might work for someone.

    EDIT: fix mentioned in other thread worked for me (except I can only add one rss and text widget, but that’s not a problem for me).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Widgets Plugin – Scriptaculous broken!’ is closed to new replies.