Support » Plugin: SG Optimizer » Widgets page no work since 5.1.0 update

  • Resolved lauradiaz

    (@lauradiaz)


    Hi!

    Since I updated today to version 5.1.0 in Appearance-> Widgets I can’t expand the Text or HTML Widgets to edit them. When I deactivate the plugin, works fine.

    * In optimization of cover, I have all the active optimizations
    * I use PHP 7.2

    The browser console gives me a series of errors:

    widgets.php:96 Uncaught TypeError: Cannot read property ‘init’ of undefined
    at widgets.php:96
    (anonymous) @ widgets.php:96
    widgets.php:100 Uncaught TypeError: Cannot read property ‘modelConstructors’ of undefined
    at widgets.php:100
    (anonymous) @ widgets.php:100
    widgets.php:108 Uncaught TypeError: Cannot read property ‘modelConstructors’ of undefined
    at widgets.php:108
    (anonymous) @ widgets.php:108
    widgets.php:116 Uncaught TypeError: Cannot read property ‘modelConstructors’ of undefined
    at widgets.php:116
    (anonymous) @ widgets.php:116
    widgets.php:124 Uncaught TypeError: Cannot read property ‘modelConstructors’ of undefined
    at widgets.php:124
    (anonymous) @ widgets.php:124
    widgets.php:137 Uncaught TypeError: Cannot read property ‘idBases’ of undefined
    at widgets.php:137
    (anonymous) @ widgets.php:137
    widgets.php:143 Uncaught TypeError: Cannot read property ‘defaultSettings’ of undefined
    at widgets.php:143
    (anonymous) @ widgets.php:143
    widgets.php:150 Uncaught TypeError: Cannot read property ‘idBases’ of undefined
    at widgets.php:150

Viewing 3 replies - 1 through 3 (of 3 total)
  • UPDATE!

    The problem occurs when I activate the Asynchronous Upload of JavaScript files that block the display!

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Please, delete the plugin, clear your browser cache and install it anew. We’ve patched that without version bump.

    Thank you very much, I have solved the problem by following your steps.

    For the next time I will wait a little before updating;)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Widgets page no work since 5.1.0 update’ is closed to new replies.