Support » Plugins and Hacks » 'widgets on pages' not working WP 3.5.1

'widgets on pages' not working WP 3.5.1

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have the same problem!!!!
    Would be great, if somebody can help to solve the problem!
    Best Regards!

    Plugin Author toddhalfpenny


    Hey there,

    Are you using the same theme donfelice?

    Do the Widgets show in the Widgets on Pages sidebars in the admin screen still?


    I had the exact same problem, widgets_on_pages stopped working last week when I updated to 3.5.1.

    However I resolved my issue by renaming all the optional sidebars, didn’t think it would work but it did.

    Plugin Author toddhalfpenny


    Hi Ic235, thanks for the info. Were you able to just use the same names as previous?

    No, I gave them completely new names.

    I’ve just tried using the original names on some of them again and the widget area was empty.

    Seems like a strange one, but my new names are working fine now.

    Plugin Author toddhalfpenny


    That is really odd… thanks for checking.
    Looks like I need to do some more testing on the 3.5.1 upgrade.

    Hey Todd,

    Have you figured out anything more about the 3.5.1 issues? I’m having similar problems to the above issues so just thought I’d check.

    Tried lc235’s ‘solution’ and it didn’t work.

    Plugin Author toddhalfpenny


    Hey Kyle,

    Yes I did some testing yesterday… seems that 3.5.1 (and the upcoming 3.6) cause issues with upgrading and also theme swapping. It seems that the widgets all get put into an orphaned state.

    This looks like my plugin will need some big changes to handle the way the WordPress core is doing this 🙁

    The only thing I can suggest in the mean-time is to re-name the sidebars and/or re-add the widgets to them… sorry.

    Lame! Any idea’s when you will get to make the changes?

    Re-naming and re-adding isn’t working for me. Any ideas?

    Having the same issues–this was a really useful plugin (and one I’m surprised was necessary rather than being incorporated into the WordPress framework itself) and I’d love to have it back!

    Any updates on this? Thanks!

    Same issue here, works on one client blog but not on the next.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘'widgets on pages' not working WP 3.5.1’ is closed to new replies.