WordPress.org

Support

Support » How-To and Troubleshooting » Widgets not working in WP 3.4.2

Widgets not working in WP 3.4.2

  • I had been able to drag/drop widgets–no problem. Just decided to add another one today and it wouldn’t work. I have deactivate widgets, flushed cache, changed browsers…I can’t think of anything else to do and have no idea why it would just stop working all of a sudden.

    Any help would be MUCH appreciated!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Lagrome

    @lagrome

    I have the same problem. All of my widgets stopped working yesterday except for the text widgets. None are in the deactivated section or anything like that. Everytime I modified a widget one disappeared. I am on self hosted WP 3.4.2.

    I have the same problem. I can’t get drag any widget. My WordPress version is 3.4.2 too.

    I’m also having same problem in wordpress 3.4.2. Is there anyone has to knew, send me your idea or suggestion to solve this problem.

    Problem : i m having right side 33 widget bar. I cant drag any active widget to the corresponding right widget bar.

    My theme is Store box theme. i.e Datafeedr ecommerce theme.

    Is there any one knew? Thanks for your help in advance.

    Same issue here.

    I can edit text widgets, but can’t any new widget of any kind. Also can’t rearrange the order. Haven’t tried deleting because I need the widgets currently showing and am afraid I won’t get them back.

    WP 3.4.2 and Genesis Corporate theme.

    I’m having the same problem. I upgraded wordpress and suddenly my widgets aren’t there for me to update. I’m running WP 3.4.2 and Custom Genesis Child theme.
    Thanks

    Try to use jQuery v1.7.2 instead of latest.

    Excuse the learning curve. I’m not sure what that means…do you have a link explaining?

    esmi

    @esmi

    Forum Moderator

    No! Do NOT deregister the version of jQuery bundled with WordPress core in favour of an older version. That will cause all kinds of problems.

    drag and drop the widgets inside the primary or secondary and call the code where i mention and place it where you want…
    <?php dynamic_sidebar( ‘primary-widget-area’ ); ?>

    Exactly esmi!
    Thats exactly what I mean.

    This is what I encountered.
    Some developers provide themes with piece of code:

    <script src="http://code.jquery.com/jquery-latest.min.js"></script>

    or something like so, hardcoded or registered… whatever.
    I changed jquery to loading from wordpress native directory ie.:

    <script type='text/javascript' src='http://YOUR_DOMAIN/wordpress/wp-includes/js/jquery/jquery.js?ver=1.7.2'></script>

    and…. widgets go back to live again. They moveable, editable and… just working.

    hI slaveek, it’s not working for me.any other option ?.

    As of yesterday I can’t access widgets across any of my sites after updating to 3.4.2 and it also affects plugin menus. The problems are on very site when viewed in Google Chrome, which is my main browser. Tried them out in Internet Explorer and they are fine. Google hasn’t issued an update and I see no mention of another WP update to correct this. Anyone know a work around?

    This is my code…repeating content after post.
    How can i solve this problem?
    please help

    (theme Page) for showing content of wordpress page
    //
    <?php if(have_posts()):
    while(have_posts()): the_post(); ?>
    <h1><?php the_title();?></h1>
    <p><?php the_content();?></p>
    <?php endwhile;
    else :
    endif;?>
    //

    (WP Page) for showing wordpress post

    //
    <?php query_posts(‘cat=4&showposts=8’); ?>
    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <?php the_title()?>
    <?php the_excerpt();?>
    <?php endwhile; endif; ?>
    //

    thanks
    Sh!hab

    Seems like this is a wordpress version 3.4.2 problem. I wonder why wordpress has not addressed this obvious bug in their current version.

    Just downloaded 3.4.2 I can drag widgets but they do not working. The ones existing ok.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Widgets not working in WP 3.4.2’ is closed to new replies.