Support » Fixing WordPress » Widgets not working (drag & drop) since 3.5 upgrade

  • Resolved Doodlebee

    (@doodlebee)


    Hey all,

    I have several sites that I upgraded recently to 3.5. All with different customized (and vastly different) themes and plugins. One client contacted me to tell me that their back-end jQuery was no longer working: no fly-out, clicking on anything that would bring up modal windows would go to a new window, and most notably, they couldn’t drag and drop any of the widgets anymore.

    After just a little bit of troubleshooting this morning, I found the issue: in all the sites that had this problem, I had been calling in Google’s API for jQuery (instead of using the WordPress native jQuery), and it was calling on an older version of Google’s scripts. As soon as I removed that call (or redid the call to Google to the most current version of Google’s API), everything worked just fine again.

    I just thought I’d share this, because I saw there were a LOT of people having this same issue, but with no solutions. (I went through about 2 pages of this exact issue on the forum, but not one with a helpful answer.) So it could be a plugin calling in an old version of jQuery, or something in your theme calling in an old version through some method that *doesn’t* just enqueue jquery. Whatever it may be, I thought I’d post my solution in case it would help someone else.

Viewing 11 replies - 1 through 11 (of 11 total)
  • this is greek to me as I am new to wordpress.
    Just loaded 3.5 on a site and am unable to get widgets to drag and drop.
    Any ideas.
    Can I fallback to the previous version?

    Thanks,
    Don

    esmi

    (@esmi)

    Forum Moderator

    @dabranch73: It is impolite to interrupt another poster’s ongoing thread with a question of your own. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    So Sorry, this looked like a single post to me and I am trying to find out how she resolved her problem. How should I have done this.

    esmi

    (@esmi)

    Forum Moderator

    Most helpful Shelly; thank you so much. I had no idea where to start looking (am am not tech savvy at all); but your post directed me to the culprit plugin (Black Studio TinyMCE Widget). Now to try and address the issue as I really want that widget back … Thanks again!

    Quick update: I am now using a WordPress visual editor and all is fine.

    Its not an Upgrade issue .. Its because of some faulty plugins , here is the video guide how to fix this problem

    rinkul – if you’d fully read my post, you’d see that I wasn’t saying it was an upgrade issue. In fact, in some cases it’s a theme issue (not a plugin).

    Standard practice is to deactivate all plugins and revert to default themes to see if the problem still persists. If it does, then you *know* it’s an upgrade issue. If it doesn’t, then you go through each plugin and theme one at a time to see what causes the issue.

    IN my case, it wasn’t a plugin at all – it w s the theme. it was removing WordPress’ built-in jQuery and switching it to Google’s API. WordPress upgraded (thus upgrading jQuery), but the API call was static – thus the conflict.

    I am currently having this issue. I am running the latest version and ONLY have bbPress installed as a plugin. I have disabled, then uninstalled still no drag and drop throughout the admin side. I have tried IE10, FireFox and Chrome, none work. Any fixes?

    @xmatter – please start your own thread – WP3.5.2 wasn’t even released six months ago, so this can’t be the same issue as yours.

    I apologize for not starting my own topic, which I will do now. I just figured the OP’s fix would be well suited for myself.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Widgets not working (drag & drop) since 3.5 upgrade’ is closed to new replies.