WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Widgets not working after upgrade – Widget Logic Visual – pinpointed

[Resolved] Widgets not working after upgrade – Widget Logic Visual – pinpointed

  • Widgets no longer working after upgrade to 3.5
    All plugins disabled and enabled one by one
    Widget Logic Visual – pinpointed as main problem.
    read master list as pertaining to jqwery.
    this plug in does contain a .js file in its list.
    widget-logic-visual/js/jquery.nyromodal.js
    This is a major plugin for me on my site.
    Any solution that is advisable besides removing plugin?
    this same plugin then affected the proper working of my tiny mce advanced

Viewing 15 replies - 1 through 15 (of 17 total)
  • esmi

    @esmi

    Forum Moderator

    Timestamp: 12/13/2012 11:50:28 AM
    Error: Error: Syntax error, unrecognized expression: #widget-logic-options-akismet_widget-%i%
    Source File: http://eic8.eng.fiu.edu/cec-new/wp-includes/js/jquery/jquery.js?ver=1.8.3
    Line: 2

    firefox

    Uncaught Error: Syntax error, unrecognized expression: #widget-logic-options-akismet_widget-%i%

    jquery.js:2

    chrome

    are there any modification I can make to jquery.js inside wp-includes to correct this?

    esmi

    @esmi

    Forum Moderator

    No. Deactivate Widget Logic Visual.

    Problem solved! I deactivated widget logic visual!

    FIX( without deactivate plugin)

    Add following code on line number 58 (in widget_logic_visual_admin_enqueue_script() function)

    wp_register_script('jquery.1.7' ,plugin_dir_url(__FILE__).'js/jquery-1.7.1.min.js');
    
    wp_enqueue_script('jquery.1.7');

    and upload jquery1.7.1.min.js in plugin js folder
    And it works fine for.

    I have opened the “show error console” to find the error. In order to add the code above I do not understand where the code is supposed to go.
    Is “widget_logic_visual_admin_enqueue_script() ” a path?
    Looking at the tree on the left, where do I go to insert the code?

    J

    @paradox_designs

    He meant (i think) to replace the code in lines 57 and 59 with the code he provided in the file widget_logic.php which is in the widget-logic-visual plugin folder (wp-content/plugins/widget-logic-visual/widget_logic.php)

    and to download jquery1.7.1.min.js from here: http://blog.jquery.com/2011/11/21/jquery-1-7-1-released/
    and put in in the js subfolder in the plugin folder (wp-content/plugins/widget-logic-visual/js/)

    BUT!

    I did that and this now prompts a new error:

    Uncaught TypeError: Object function (a,b){return new e.fn.init(a,b,h)} has no method ‘widget’ load-scripts.php:5
    Uncaught TypeError: Object [object Object] has no method ‘tabs’ widgets.php:4344

    khan, any thoughts?

    Thank you for reporting your results J, I appreciate it.,
    Was about to implement this as well.
    Yet will now wait to here back from Khan – hopefully.

    Deactivated all plugins, then widgets were working. then reactivated one by one and found the plugin (darn cant remember which one it was) and alls good. thanks to all the volunteers that make this all possible.

    Kudos…

    James

    open widget_logic.php go to line 132
    and change
    if ($number==-1) {$number="%i%"; $value="";}
    to this
    if ($number==-1) {$number="__i__"; $value="";}

    Wow, thank you so much Nindya. I hope this works. I will make the suggested modifications and report back if it is successful. Once again thank you 🙂

    Perfect, It worked fantastically 🙂 The modification suggested are now complete and in working order. I really appreciate it.

    Issue is now resolved.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Widgets not working after upgrade – Widget Logic Visual – pinpointed’ is closed to new replies.