WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Widgets Not showing, using Meta-Morphosis theme

[Resolved] Widgets Not showing, using Meta-Morphosis theme

  • Any wordpress experts out there??…i’m hoping someone would assist me with our new blog theme. I’m using Meta-morphosis theme, which uses the jQuery Looped-Slider in the footer for the Widgitized area – for some odd reason the widgets are not showing, but i can see them in the page source…i’ve been going crazy trying to figure this out – if anyone is willing to help here’s the site: blog site – check the bottom footer part (widgets not showing) then check the page source…and you’ll see the widgets there – very strange :o(
    Muchly appreciate ANY assistance!

Viewing 5 replies - 1 through 5 (of 5 total)
  • div is hidden?

    I see the theme has the follwing CSS (style.css, line 402)

    .container div {
      left:0;
      opacity:0;
      padding:0 20px;
      position:absolute;
      top:0;
      z-index:0;
    }

    The opacity set to 0 doesn’t help you 🙂

    spstieng: thank you for your reply!!!
    Regarding the opacity you mentioned in the style.css, line 402 – do i just remove the opacity???
    I’m not sure what to do exactly…yet! but i’m gonna try and remove the opacity, see what happens and will be back here shortly 🙂

    Blessings!

    Ok, i’m back! First of all spstieng, thank YOU so much for your assistance! I changes the opacity to 100, and the widgets are showing!! – very cool.

    There is a couple of problems still though.
    1. The recent posts & Links are only showing two lines, when there should be 10 recent posts and about 6 links ???

    2. The fourth widget is overriding (on top of the first Meta widget) and when you click on the ‘next’ button to go to the next slide, it doesn’t move, in fact it just refreshes the same page. Any clue as to why this is happening???

    Here is the footer.php file source (the widgets area):

    <!-- start Widget slider -->
        <div id="loopedSlider">
            <div id="slider-top"></div>
            <div id="slider-block">
                <?php if (is_sidebar_active(4)) { ?>
                <ul class="nav-buttons">
                        <li id="p"><a href="#" class="previous"><img src="<?php bloginfo('template_directory'); ?>/images/btn-prev.png" alt="<" /></a></li>
                        <li id="n"><a href="#" class="next"><img src="<?php bloginfo('template_directory'); ?>/images/btn-next.png" alt=">" /></a></li>
                </ul>
                <?php } ?>
                <div class="container">
    
                        <?php if (is_sidebar_active(1) || is_sidebar_active(2) || is_sidebar_active(3)){ ?>
                        <div id="slide-1" class="slide">
                        	<ul class="widget"><li><?php dynamic_sidebar(1); ?></li></ul>
                        	<ul class="widget"><li><?php dynamic_sidebar(2); ?></li></ul>
                        	<ul class="widget last"><li><?php dynamic_sidebar(3); ?></li></ul>
                        </div>
                        <?php } else { ?>
                        <p>This area is controlled in your WP admin under <strong>Apperance > Widgets</strong>. You need to <a href="<?php bloginfo('template_directory'); ?>/images/help-widgets.png" >add your desired widgets</a> to one of the 9 widget areas (Footer1-9).
                        <?php } ?>
                        <?php if (is_sidebar_active(4) || is_sidebar_active(5) || is_sidebar_active(6)){ ?>
                        <div id="slide-2" class="slide">
                        	<ul class="widget"><li><?php dynamic_sidebar(4); ?></li></ul>
                        	<ul class="widget"><li><?php dynamic_sidebar(5); ?></li></ul>
                        	<ul class="widget last"><li><?php dynamic_sidebar(6); ?></li></ul>
                        </div>
                        <?php  } ?>
                        <?php  if (is_sidebar_active(7) || is_sidebar_active(8) || is_sidebar_active(9)){ ?>
                        <div id="slide-3" class="slide">
                        	<ul class="widget"><li><?php dynamic_sidebar(7); ?></li></ul>
                        	<ul class="widget"><li><?php dynamic_sidebar(8); ?></li></ul>
                        	<ul class="widget last"><li><?php dynamic_sidebar(9); ?></li></ul>
                        </div>
                        <?php  } ?>
    
                </div>
            </div>
            <div id="slider-bot"></div>
        </div>
        <!-- end Widget slider -->

    Ok guys…i’m all good yay!!!
    Solved the problemo…

    My Appreciation for taking the time to respond to me…
    Blessed light,
    Aline

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Widgets Not showing, using Meta-Morphosis theme’ is closed to new replies.
Skip to toolbar