Support » Fixing WordPress » Widgets missing in WordPress 5.8 upgrade

  • I upgraded to WordPress 5.8 and now the dashboard – appearance-widget page is blank. Nothing is showing up. I checked under customize in the theme and found only the blocks but not widget options. Only widgets I have already set up are showing in the theme. The others are no longer accessible. What do I do. I want to use my footer widgets to show my pages and other options that had been available with WordPress 5.7. The new upgrade has changed everything to blocks. Can this change be reversed so I can customize my website. I need my widgets nack

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Can you check the server error log?

    Also, do you have a full backup of your site?

    @adetutuijose While on the Appearance -> Widgets page, it’d be great if you could also open the browser developer tools, and look at the console tab to see if there are any errors in red text.

    > Only widgets I have already set up are showing in the theme. The others are no longer accessible. What do I do.

    There are block versions of the widgets, I’d recommend trying those first to see if they work for you. There are small differences—blocks don’t automatically have a title so a separate heading block is needed.

    Thread Starter adetutuijose

    (@adetutuijose)

    Thanks. I do not know where the developer console is but I checked Cpanel and there are no errors on record for today or yesterday. The last errors were recorded on Sunday.
    Because the website is big, I keep only 1 full backup at a time as I have a shared server. I made many updates before I discovered the widget issue. I still have my last backup but I made so many major changes today I am afraid to wipe out the old backup from a few days ago.

    > Thanks. I do not know where the developer console is but I checked Cpanel and there are no errors on record for today or yesterday. The last errors were recorded on Sunday.

    @adetutuijose Which browser do you use? I’m happy to provide some more detailed instructions for checking the developer tools.

    I made many updates before I discovered the widget issue. I still have my last backup but I made so many major changes today I am afraid to wipe out the old backup from a few days ago.

    Download the backup, and try to create a local version of the site in your computer to find out the issue and check the error log

    I am facing the same issue. Nothing shows up on widget page.

    Here is a screenshot of the developer console.
    https://prnt.sc/1gsbcex

    @anuranjanverma I have a feeling the error is coming from a plugin. The top error where it says wp.editPost is possibly a plugin trying to use one of the post editor APIs, but that wouldn’t be present in the widget editor.

    Do you have other plugins active? If so, you could try disabling plugins one-by-one and testing the page, hopefully that will help determine whether a plugin is causing the issue. If there’s a particular plugin that you find, definitely share the details here and I can do some further testing.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.