Support » Theme: Ascend » Widgets dont show PNG/jpeg images or linked buttons

  • Resolved theillustrator

    (@theillustrator)


    Hi,

    I have Kadence, Ascend and Gutenberg.

    On a page on my website, I selected Sidebar Layout, set to “yes”. And a new custom made Sidebar.

    I created the custom sidebar, and gave it a name “xxxxx”.

    In Appearance / widgets/ I used Custom HTML widget, pasted in a code similar to a PayPal Donate button link. And I also added an additional “Image” widget, with image from Media Library, and a link attached to the image to go externally (To PayPal).

    At first try nothing visualla except text names of widgets, showed up LIVE on the website. No images, no buttons. Just names of widgets.

    I then tried to redo the whole procedure, then an image linked in image widget showed up.

    But without knowing why, the image in image widget, doesnt show up any more in the Sidebar LIVE.

    No matter what I seem to do, only Title text of a widget and image description text shows up. And only once have the image wdiget show the image. And never have the custom HTML shown any button-link images.

    To add to the mystery, despite no Button-link image is visable, the area it shoudl show up in, does work as a link to click on

    Any ideas?

    Thanks in advance
    / Stefan

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hey,

    Can you link to the sidebar so that I can take a look at how it’s outputting the html? I can also check the html to make sure nothing is missing.

    -Kevin

    Hi Kevin,

    Thanks for looking at it. Here is the Link …

    / Stefan

    It appears that something in your lazy load settings is making the image opacity 0. Try adding this CSS to Theme Options> Custom CSS and let me know if it forces the image to show:

    .sidebar .widget .widget-inner img {
        opacity: 1 !important;
    }

    -Kevin

    Hi Kevin,

    Doesnt seem to, unfrotunatly. I added it in custom CSS under Theme options.

    Ps. I will remove the link now,but you have it on your end

    Big thanks as useal.

    / Stefan

    Did you clear your cache after adding it? I’m not seeing the CSS in your custom CSS box.

    -Kevin

    Hi,
    yes, I believe so.
    Did you mean cache in wordpress or the web browser?

    Whatever plugin you’re using for your cache, not the browser.

    -Kevin

    Figured 🙂
    Sorry, doing it right now. – Doing two things at the same time. Illustrating for a travel catalogue. Lot of swimmingpools and palm trees, and I am in north europe with rain and dark clouds outsie.

    Stay tuned

    Using Litespeed btw.

    Trying to find that darn “empty cache”.

    Since your site isn’t public yet, there really isn’t a point in having a cache running.

    You should consider disabling the plugin until you’re finished with your site to make sure you’re always seeing the most current version of your site while developing it.

    -Kevin

    My site IS public. Does it say on your end that it is not public?

    Ps. Clicked Purge pages. I am not a friend with Liespeed or any other cache pligin. Rarely touch it these days, for some reason

    Ah, I just assumed since you don’t like sharing your URL that it wasn’t finished yet.

    The image is showing now on my end.

    -Kevin

    So bizarre. I suddenly saw the button and image link and the refreshed the browser, and it vanished again.

    / Stefan

    Kevin,

    I made a changed that wrked.
    Basiically I created a button image of my own, uploaded to my business PayPal and put that into my page. And that works.

    /Stefan

    Cool! Glad you found a solution.

    -Kevin

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Widgets dont show PNG/jpeg images or linked buttons’ is closed to new replies.