Support » Plugins » Widgets don’t drag and drop :)

  • Please help. I’m using WP 2.3.1 and Automatic says this version doesn’t need a sidebar widgets or widgets because it’s already in the core of the new version.

    But why i can’t drag my widgets and drop them? I tried uploading the sidebar widget but when I activate it, I get error and the plugin can’t be activated.

    What’s the problem? thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Deactivate the Sidebar widget plugin, delete all files related to that sidebar widget plugin.

    Change your them to the WordPress Default 1.6 theme.

    Try and use the Widgets under Presentation tab.

    Before I even upgraded to 2.3.1 I deactivated widgets and deleted the plugin, but now after the upgrade I cannot drag and drop the widgets, they simple highlight like text. It seems I’m not the only one either.

    Trying the suggestion to use the default theme gave an error related to no sidebar defined, widgets were not an option at all.

    Help! None of the themes I have switched to will properly display widgets since the upgrade.

    What plugins do you have installed? I just found out that one that I’m using kills drag and drop when you’re using Internet Explorer.

    I also have this problem on 2.3.1. I deactivated all plugins and swithced to the default theme and it does not work. IE reports a javascript error:

    Object does not support this property or method.

    For this line:

    jQuery(‘#widget_stags-1control’).Draggable({handle: ‘.controlhandle’, zIndex: 1000});

    This is the first instance of .Draggable() on the page.
    There is also an unterminated string constant error, I believe it’s in the jquery/interface.js file because it reports it at character 65314.. but couldn’t find anything wrong looking at it, although the compressed output is pretty confusing.

    Anyone have any ideas on this?

    Do you have Kings Widgets or Kings Framework?
    Both are known to cause those problems.

    No, I have neither, and as mentioned disabled all plugins with no change. I think I will look at the database to see if there is a way to set the widgets manually..

    heh… yeah it looks like i should be able to set the wp_options row for “sidebars_widgets” which contains a serialized php array.. but not sure the correct format to use.

    can somebody with a customized sidebar execute this sql query and let me know the result?

    SELECT option_value
    FROM wp_options
    WHERE option_name = ‘sidebars_widgets’

    Mine just returns a:1:{s:13:”array_version”;i:3;}
    because I haven’t been able to customize the sidebar yet.
    Need to know the data format so I can set which widgets to use.. I tried a few things but they either gave errors or re-set to the above..
    Hopefully future WP versions use more robust drag n drop..

    OMG why this issue isn’t solved… It’s so strange!!!
    I have this drag/drop problem with Safari & Firefox, on a hosted site and on my self hosted site…

    Hello all.

    I’ve solved this problem with a little hack on a php file. In my case Draggable could not be found because of a transparent proxy that malforms urls created by PHP.

    I’ m no coder, but I had to make a hack to get wordpress widgets drag
    and drop working on my enviroment.

    At first I thought my blog was broken, maybe by a plugin or upgrade.
    Then, while in vacation at the US , it started working again. When I
    came back drag and drop got messed again and I noticed that it also
    happened with blogs.

    After a lot of searching, backups, reinstalling, #wordpress, etc…

    I’ve found the problem and I was able to fix it (I hope without
    creating further problems)…

    Right now I’ m working in Tunisia, and all Internet traffic pass by a
    transparent proxy that blocks all kind of content considered to be
    inappropriate by the government. We can’ t see the proxy, it’s not
    browser configured, it is at country’s backbone.

    Probably there is a misconfiguration somewhere, and when my browser tries to load interface.js on the url:

    It gets the 404 error.

    If I try:

    It shows properly the interface.js sourcefile.

    So I make a little editing on script-loader.php, on line 77:

    $this->add( ‘interface’, ‘/wp-includes/js/jquery/interface.js’,
    array(‘jquery’), ‘1.2’);


    $this->add( ‘interface’, ‘/wp-includes/js/jquery/interface.js’,
    array(‘jquery’), ”);

    The url it loads now is:

    and since the proxy does not block it, I got drag and drop working again.


    Camelo Manco

    maybe there is a method to solve this problem , “Drag and drop don’t work in WordPress Widgets”

    I have neither, and as mentioned disabled all plugins with no change.

    Well, I am convinced that the problem IS in the interface.js / JQuery.js / widget.php combo. Obviously NOBODY bother(s,ed) to test the WHOLE package before they release it to the public. Telling somebody to disable / enable plug-ins, themes , underwear just doesn’t make sense and only emencly annoys folks like me. The BUG IS and HAS BEEN in WordPress since 2.2.x release, but nobody ever address it.
    BTW, even loading this page triggers error message.

    It is SO amateurish. Same people bitch about Microsoft’s software, and yet I have yet to experience that much bs, as I do with MANY opensource crap.

    I had the same trouble when I upgraded. I just reinstalled, (redownloaded) the upgrade and followed the directions to the letter, over wrote files but not dir wp_content and themes and everything works fine again.

    bszuta: How dare they! I suggest you ask for a full refund as you delete the software from your web server. Hang on! You didn’t pay a cent for it! Now either grow up and be more respectful of the work others do for free, or go bitch somewhere else!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Widgets don’t drag and drop :)’ is closed to new replies.