WordPress.org

Support

Support » Installation » Widgets don’t drag and drop as advertised

Widgets don’t drag and drop as advertised

  • Just installed 2.8 on a new domain.

    The widgets say to drag and drop onto the sidebar, but in Firefox and Safari, they don’t work – they don’t drag. I can’t grab them, clicking on one produces a little hand icon, but the hand never closes and the widget never moves. Help?

    — Note —

    Just killed that installation and installed again. Still broken. I’ve tried refreshing pages, restarting browsers, nothing works. What’s the point of having an installed blog if the sidebars are completely unusable?

Viewing 15 replies - 1 through 15 (of 75 total)
  • Moderator Andrew Ozz

    @azaozz

    Do you see any js errors? Also it’s possible that the installation zip didn’t unzip properly, perhaps download another one, unzip it, delete wp-admin and wp-includes and upload fresh copies.

    The widgets screen also has accessibility mode that can be turned on from Screen Options and can work when js is disabled.

    Hi cheespuppet,
    Did you try disabling your custom plugins? (remember to write down which were enabled). I was about to downgrade to 2.7.1 but I gave it one more try. I had the exact same problem and it was caused by a plugin. After that I optimized my database with Lester Chan’s WP-DBManager just to be sure and it’s now all working dinky donky.

    I had the same problem in FF3.0.10. I found that by dragging the widget over the top of one of the others the dashed box then appeared to drop it in at the bottom of the stack. I could then drop the widget in the dashed box. I could then configure and save it. BUT the Next Gen Gallery widgets don’t appear on my page. 🙁

    Not working here too. I use Firefox 3.0.10. The Widgets on the Dasborad cannot be dragged and also on the Widgets screen I cannot move anything arround.
    Anybody found a solution?

    Also, when you try to reorder the widgets, dragging the widget to its new location works but there’s no save button so I assumed it did it without doing a save. No luck, still in the same position.

    Bill

    PS: WordPress 2.8

    I automatically upgraded my test blog with no problems, but drag and drop will not work with Firefox 3.0.10 — it’s as if the cursor is dead. I tried with IE8 and no luck there either; almost everything except the widget I wanted to drag becomes highlighted and I can’t even select the widget in question.

    Quite a disappointment, although I must say FF has been nothing but trouble and junk for past three versions. Because of that I fully expected drag and drop to work in IE8.

    I was having the same issue and I found this article and fix online.

    http://rickbeckman.org/thesis-15-on-wordpress-28rc/

    I tried it and now my widgets drag and drop and stay put in Safari, Firefox and Flock.

    Yeah but this seems to be the case only if you have the Thesis Theme installed (which I don’t).

    B

    Thank you, jsieghart. I use Thesis and Rick’s solution took care of my problem. Haven’t tried it yet with IE, but FF and widgets are working fine now.

    It seems none of the javascript in my admin panel is working. No drop-down menus or anything “fancy”. I don’t have any javascript errors (and yes, javascript is enabled on my browsers), it just seems to not be working.

    Same thing happens to me, I’m using the latest Firefox and I can’t drag and drop widgets and the widgets in my sidebar are “locked” in place and won’t open to let me edit.

    I just took a look at the source code, and it seems there was an oddly commented line of code just after the <body> tag in the admin panel.

    <body class="wp-admin no-js  index-php">
    <script type="text/javascript">
    //<![CDATA[
    (function(){
    var c = document.body.className;
    c = c.replace(/no-js/, 'js');
    document.body.className = c;
    })();
    //]]>
    
    </script>

    Not sure how to take that out or even why thats there. Could be causing some problems. I’m going to keep looking into it.

    Nevermind, I found it and commented it out and it had no effect whatsoever.

    It is most likely a plug in compatibility issue. I had the same error and had to deactivate a plug in that I much enjoyed… category icons.

    That worked for me. Interesting. Hope they fix it!

    Moderator Andrew Ozz

    @azaozz

    Unfortunately there are plugins that include their js on every page in the admin when it’s only needed on the plugin’s config page. Some of this js interferes with the default scripts.

    Hopefully the authors of these plugins will fix them, leaving comments on the plugin’s web pages may help that too. In the worst case the widgets page can be used in accessibility mode (switch from Screen Options) that doesn’t use the jQuery and jQuery UI scripts.

Viewing 15 replies - 1 through 15 (of 75 total)
  • The topic ‘Widgets don’t drag and drop as advertised’ is closed to new replies.
Skip to toolbar