Support » Fixing WordPress » Widgets dashboard not working in 2.9.2

  • Resolved mickeyshout

    (@mickeyshout)


    I just did a fresh install of 2.9.2 and the widgets dashboard is not working properly. When I try to drag a widget to the sidebar, it simply highlights the text, and will not drag. I have tried this with the default theme and several others. Same results. I have no plugins activated. Can anyone help?

Viewing 15 replies - 1 through 15 (of 31 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    Thanks for the help! I just tried that–downloaded WordPress 2.9.2 again, deleted my wp-admin and wp-includes folders, and replaced them with fresh versions from the new download. Still no luck. Can’t get anything to work on the widgets dashboard.

    My apologies for posting about this twice–I couldn’t find my original post and I thought it had never gone through.

    I am having the same exact problem. I too have installed the newest version of wordpress and my widgets dashboard is still not working. Any help on this would be greatly appreciated!

    I just deleted all of my plugins and now the widget is working ok.

    esmi

    (@esmi)

    Forum Moderator

    @mickeyshout: It could possibly be a memory issue.

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define(‘WP_MEMORY_LIMIT’, ’32M’);

    4. Talk to your host.

    Hi, i have the same problem,
    I download and Upload to my server the new version of WordPress, i install all again, all are new, but don’t work, and my memory limit is 32, what i can do?

    Thanks,
    Greetings From Chile

    The same thing happened to me and I’ve tried the hints above. I don’t even have any plugins to delete! I thought it could be my theme (a Wootheme) but have switched back to Kubrik and the problem is the same – no drag and drop of widgets, and the Screen Options dropdown doesn’t, er, drop down.

    Hi, i have the answer for the problem, in my case, was a pluggin old, but work… maybe it’s your problem too

    Greetings!

    Possibly a javascript error? Of course like everyone else, widgets don’t work, upload insert don’t work, clicking on screen options does nothing. Not working in IE7 or firefox. It sure would be nice to be able to use the widgets feature and other cool stuff depending on JScript.
    tried disabling plugins, fresh install, own directory install, bare bones, no luck.

    I get this Jscript error in my IE7 browser when I load the admin interface.
    error: “Done, but with errors”

    Line: 2
    char:77
    error: invalid character
    code:0
    URL:http://mydomain/wp-admin/

    Line: 2
    char:1
    error: ‘sack’ is undefined
    code:0
    URL:http://mydomain/wp-admin/

    Line: 10
    char:2
    error: ‘g_execphp_feature’ is undefined
    code:0
    URL:http://mydomain/wp-admin/

    Line 2
    char 300
    error: invalid character
    code:0
    URL:http://mydomain/wp-admin/

    Same problem here, with all browsers in all platforms. This is a server side error…
    Any ideas?

    Do you have an .htaccess file that you customized. I recently posted an .htaccess file that definitely blocks all hacking attempts and also unfortunately blocks you for some WordPress functions involving plugins and yes the drag and drop function in the widgets panel. Several of my clients had been hacked on GoDaddy so I added that very restrictive .htaccess file to their hosting accounts. By renaming your .htaccess file temporarily you should be able to determine if this is your issue. I maintain several clients WordPress sites and they are using WordPress versions 2.9.1 and 2.9.2 and the drag and drop widget function is working correctly…as long as the .htaccess file is temporarily renamed.

    I’m having the same problem with 2.9.2. I can’t drag or otherwise modify any widgets.

    I’ve tried: disabling all plugins, switching to default theme, overwriting wp-includes and wp-admin directories with fresh files and have verified that I have 32MB of memory in PHP. I don’t have a custom .htaccess file.

    Anything else that I can try? I’m planning to try moving back to an older version of wordpress.

    I just downgraded to wordpress 2.9.1 but I still have the same problem!

    esmi

    (@esmi)

    Forum Moderator

    Basic troubleshooting steps:

    – deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switch to the default theme to rule out any theme-related problems

    rese the plugins folder via phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-upload the wp-admin and wp-includes folders from a fresh download of your version of WordPress

    As mentioned above, I tried all of the basic troubleshooting steps with no success. I also tried using “accessibility mode” through screen options, but the screen options menu isn’t accessible either.

    Is there anything else that I can try?

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Widgets dashboard not working in 2.9.2’ is closed to new replies.