Support » Fixing WordPress » Widgets Broken in WordPress 3.3.1

  • Dave333


    Ever since upgrading to WordPress 3.3.1 yesterday I’ve lost the ability to add Widgets. I can add, edit and delete them while in the admin but as soon as I look at the website the new widget I added is not showing. All the old widgets still show.

    I’ve tried putting simple text in a text widget.

    I’ve tried moving that widget to the top of the list of widgets

    I’ve tried deleting other widgets in case I had too many.

    I’ve tried switching browsers and adding the widget again.

    Nothing will allow me to add a new widget and have it show on the website.

    This was never a problem before and I haven’t changed anything since updating to WordPress 3.3.1.

    I read in another string that WordPress has changed the way it deals with widgets now so I assume there will be others with the same problem I am experiencing. If anyone has figured out a solution please share by commenting here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi


    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.



    Thanks for the prompt reply esmi.

    I tried deactivating all plugins.

    I tried switching to Twenty Ten (TwentyEleven doesn’t have side widgets by default) but that made ALL my widgets disappear. I’m not familiar with TwentyTen so not sure if that helped. The new widgets didn’t magically appear in any case, with either TwentyEleven or TwentyTen.

    I tried resetting the plugins folder.

    I tried replacing the wp-admin and wp-includes folders

    None of these attempts made the simple test text widget appear on my site.



    OK, well I am not sure what happened but it is working now. Here are some points that might help others.

    I tried one more thing suggested by Chrome Orange on another thread:

    if you go to the admin section of your website ( and login while using the Google Chrome browser.

    Find some clear space in the browser window and right click.

    Now choose ‘inspect element’ from the context menu that opens (if you don’t see this then find a different spot and right click again).

    The screen will split in half horizontally and in the bottom section you choose the ‘console’ tab and (hopefully) you will see an error there that you can fix).

    I noticed that the Podpress plugin was showing an error so I deactivated it, added a text widget and it worked. I then reactivated Podpress plugin but it didn’t break the widget functionality.

    I don’t know which of the things I tried worked. I had deactivated Podpress plugin before in a previous troubleshooting attempts when I turned off all plugins but it didn’t help the situation then. It was only after trying all your suggestions and then turning of and on the Podpress plugin that I got my site working again as normal.

    Good luck to the rest of you who have upgraded WordPress to 3.3.1!!!



    Sorry, I spoke to soon. It broke again.

    So I deactivated the PodPress plugin again and emptied my browser’s cache and the widgets are staying put and behaving as they should again.

    Emptying the cache is the key to many troubleshooting problems. Often changes are not reflected when you reload the page due to the cache showing an older version of the page. So while you think you are looking the website after the changes, you are in fact still looking at a version of the site PRIOR to the changes. It’s a huge annoyance and trips up so many people.



    same problem! only with widgets page.



    @manwell77: Please post your own topic.

    Recently in my blog this behavior affected also other pages not only the widget page. I found that the problem was the “W3 Total Cache” Plugin. I emptied all caches and deactivated the plugin. Now everything’s working fine in every page. Seems that the problem resides in the admin menu bar that shift-down in pages affected.

    This happened to me after upgrading to 3.3.1. I used the Google Chrome right-click “Inspect element” suggestion from a previous post and found that the Frontend Editor was the offender. Deactivated it and all is well.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Widgets Broken in WordPress 3.3.1’ is closed to new replies.