WordPress.org

Support

Support » How-To and Troubleshooting » Widgets are broken in 2.8.6 – can’t move them around

Widgets are broken in 2.8.6 – can’t move them around

  • olahaldor

    @olahaldor

    I’ve just installed WP 2.8.6 on a new domain I got last night. Earlier I have been running 2.8.4.

    In 2.8.4 I had no problems adding, removing or adjusting the placement of widgets – however in 2.8.6 I cannot do this anymore. When I hover the mouse over the title bar of a widget, click and drag, it’s only making a selection of the text – I cannot drag the widget over to wherever it should go.

    First I thought it was probably a Safari issue (most super custom made stuff won’t work in Safari, like Joomla for instance..) so I tried Firefox, only to find the same result – click and drag results in marked text and elements, not moving the widgets around.

    I’m on a Mac, but that shouldn’t make any difference.. ?

    Edit
    I noticed there’s a new box or description in the widgets page. It says
    Drag widgets from here to a sidebar on the right to activate them. Drag widgets back here to deactivate them and delete their settings.

    Now, I don’t see anything to the right………
    http://bildr.no/view/534233

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’ve had similar problems which turn out to be theme related.

    Have you tried switching back to the default WordPress theme just to see if the issue is theme related?

    If that doesn’t fix it then, I’d try disabling plugins then trying the widgets.

    Good luck.

    Dan.LaSota

    @danlasota

    I am seeing the same behavior in Safari 4.0.4, Firefox 3.5.5, and Opera 10.1 on Mac OS X 10.6.2 using wordpress version 2.8.6. On most of my wordpress sites.

    However, on one site, also running 2.8.6, I can use the widget editor. I’ve examined the plugins, and I’ve determined that that is not the cause.

    Any clues as to what is causing this?

    Dan.LaSota

    @danlasota

    Followup: It seems that all the ajax functions are not working. Even in the wp-admin sections which are largely theme independent, all the little drop down menus for each edit section do not work.

    Still looking for clues.

    PHP 5.2.11 if that matters.

    oldrunk

    @oldrunk

    I just found out that I can’t move my widgets in any of my blogs…I see that this topic is unresolved…Will someone please look into this…I tried switching back to the original word-press theme but it still does the same thing…None of my widgets will move…

    ecstatic

    @ecstatic

    I had this exact problem, broken widget control page, no ajax in the Admin area, on a brand new install with no changes from the defaults. Recurred multiple times consecutively. IE and FF.

    Turned out to have been something caused by the Microsoft Web Platform Installer, beccause the problem went away when I stopped using that and manually installed.

    ThorHammer

    @thorhammer

    Thanks for the 2.8.6 warning. I’ll wait with this upgrade.

    oldrunk

    @oldrunk

    I have one blog that I manually installed & two I installed with fantastico…I don’t really understand what you are talking about with the Microsoft Web Platform…Please explain in Dummy terms…I fall into that category…

    ecstatic

    @ecstatic

    Web Platform goes with iis, it’s an installer

    http://www.microsoft.com/Web/

    Amin

    @amineng

    Hi all.
    I have this problem everywhere
    can’t move Widgets around
    &
    http://bildr.no/view/543410
    Does not work
    Java enabled also
    thanks

    oldrunk

    @oldrunk

    Ok I see what the installer is…but I didn’t use that to install my blogs…Anybody got any idea’s on how to fix my problem

    oldrunk

    @oldrunk

    I found that if I disable my pluggins I can move my widgits…But that is a real pain to have to go thru

    Amin

    @amineng

    it is not for me
    My problem is java
    Or WordPress
    or server
    How Understand?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Widgets are broken in 2.8.6 – can’t move them around’ is closed to new replies.
Skip to toolbar