Support » Fixing WordPress » Widgets Admin Page Not Working

  • We recently upgraded to 2.8.4. After the upgrade on two sites, our widgets admin page does not work. The page is visible but we cannot drag widgets to or from the sidebar, widget settings cannot be accessed and the screen options menu does not work.

    Since we can’t access the screen options menu, I can’t change the accessibility mode.

    We run the Thesis theme on our sites. I have switched to the default theme with no change.

    I deactivated ALL of our plugins – no effect. (I did deactivate all the plugins during the upgrade)

    I took out some customization in thesis – no effect.

    I tried restoring the old version of widgets.php but that got me an error. I also tried copying in the widgets.php from the new install with no effect.

    We have an older site I tried a practice run at the upgrade on and it behaves a little different. The widgets aren’t accessible but the screen options menu is. I tried adding Thesis there, but that didn’t break it.

    The problem is the same in Firefox and IE and different machines.

    Any suggestions?


Viewing 13 replies - 1 through 13 (of 13 total)
  • Have you tried resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.If you can manage the phpMyAdmin approach, use it. Experience suggests that it offers the best success rate in eliminating problematic plugins.

    Thanks Esmi – Tried both methods with no luck.

    I just upgraded to WordPress Version 2.8.4.
    I use the theme Clean Home 1.2.0.
    The Widgets Admin page at /wp-admin/widgets.php does not work — there is absolutely no interaction.
    There is no drag and drop.
    Clicking on any widget simply adds a token to the URL, ie: /wp-admin/widgets.php#available-widgets.

    I have not disabled any plugins or changed the theme because it seems like a waste of time when it’s obvious this is due to a failure in WordPress Admin’s javascript.

    Firebug tells me the following request fails:,common,jquery-color,jquery-ui-core,jquery-ui-sortable,postbox,jquery-ui-draggable,jquery-ui-droppable,admin-widgets&ver=82de755528af303bcbf947f7ca91f741
    404 Not Found

    This seems far more relevant than the plugins and themes.

    The file /wp-admin/load-scripts.php exists when I log into FTP. I do have /wp-admin/js/. It contains 59 Files.

    I don’t know the syntax the file uses, but if:
    Are supposed to be the names of .js files in /wp-admin/js, no such files exist.

    I’m a newish WordPress user, so the guidance of someone more familiar with the admin javascript functionality would be appreciated.

    I’m have the same problem with my sidebar widgets as well. I hadn’t make the connection with the WP upgrade. Are there any bugs in the new version that could cause this?

    I said above that what I experienced was obviously a javascript failure. That’s ultimately what it was related to, in a roundabout manner, and I feel it’s obvious when the page loads looks beautiful but the javascript-reliant links & features don’t do anything.

    So if you can load the widgets page and see everything with no errors, but the javascript isn’t kicking in (no dragging, dropping, or response to clicking on widgets) that would be the first thing to check.

    Apparently some people are experiencing a similar, but not identical problem with the Thesis theme — and that there’s a new version. So if you’re on Thesis do take a look at that.

    You can test out the javascript relationship by disabling javascript in your browser — I used Firefox’s web developer plugin to check that and, sure enough, I got a non-javascript-compatible version of the widgets admin that worked just fine.

    As I mentioned above, I was also able to see with Firebug’s net console that load-scripts.php wasn’t getting included…but since it appeared to be in the right place, I next thought that perhaps the automatic update I did had misplaced or failed to add some new scripts. I didn’t see some of the scripts in /wp-admin/js, so that seemed plausible.

    But I took a look at load-scripts.php and at least some of the scripts specified to load are in /wp-includes/js — that’s where the jquery is, anyway. It looked like all files were accounted for, but I also determined that load-scripts.php doesn’t use PHP to return a 404 if it fails to find a script file (well, or not that I saw).

    Those possibilities investigated, I figured the 404 had to be an override on the server level, so I took a look at my .htaccess file.

    My mystery is solved, because in my case load-scripts.php was failing because of a mod_rewrite rule from Perishable Press’s 4G blacklist. Specifically:

    RewriteCond %{QUERY_STRING} ^.*(request|select|insert|union|declare|drop).* [NC]

    As you can see, jquery-ui-droppable, has “drop” in it, so the rewrite rule kicks in and the load-scripts.php can’t load. So if anyone else is using the Perishable Press blacklist, take a look at that condition. I just took out “drop” for the moment, but another way to do it is to have the expression check for a space after the words.

    There are a bunch of other reasons the javascript might not be kicking in, though. And it’s certainly possible it’s related to a plugin or theme — but I wouldn’t make any extreme attempts to monkey with innocent plugins until you ascertain that the required scripts are actually being loaded.

    Try going directly to,common,jquery-color,jquery-ui-core,jquery-ui-sortable,postbox,jquery-ui-draggable,jquery-ui-droppable,admin-widgets&ver=82de755528af303bcbf947f7ca91f741 (replace with your URL) and make sure it has the jQuery core and UI files in it. Since it’s combined & compressed you can’t actually use it as a checklist for each of the files listed, but there are comments and it will at least serve as a simple indicator.

    I hope it works out!

    I have an even worse problem after the upgrade. I get no errors but no page is displayed.
    When I view source, I see just see:

    <!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 4.0 Transitional//EN”>
    <META content=”text/html; charset=windows-1252″ http-equiv=Content-Type>
    the site luckily is not affected.

    if anyone fins a solution. please do let me know.

    I am having the same problem. I’m using WP Version 2.8.4 and the Atahualpa Theme at Cannot drag the widgets. Any chance I can revert to the previous WP version??

    Some PHP errors may be suppressed and appear only in the Apache error log — see if you can get access to view it, it may give you some more information.


    That shows that you have (at least some of) the scripts, so they should be initialized…but open up Firefox with Firebug and see if you get an errors when things are loading or when you attempt to move a widget.

    I’m happy to help but without some possibilities ruled out through a troubleshooting process it’s impossible to isolate a specific problem.

    If you’ve checked that you have all the javascript & php files and you’re still experiencing problems, do as the first poster(s) suggested and move onto disabling plugins and changing your theme to see if there’s a conflict.

    I’m sure you can roll back, but as a newish WP user I’m afraid I don’t know how.

    @rhyaniwyn – problem solved. I needed to enable the widgets. <sigh>
    Widgets > Screen Options > Enable

    Thanks for your help!

    I’m running 2.8.6 and are having the exact same problem. I tried disabling all plugins and reverting my theme to the default ones with no avail.

    @rhyaniwyn – You saved my brain. I used the blacklist. Wow……..

    I never even considered the blacklist causing a problem. Thanks!

    Did you try define( ‘CONCATENATE_SCRIPTS’, false );

    This should solve the problem..

    Did you try define( ‘CONCATENATE_SCRIPTS’, false );

    This should solve the problem..

    Thanks, it helped!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Widgets Admin Page Not Working’ is closed to new replies.