Support » Plugins » Widgets Admin Can’t Drag and Drop

  • Resolved robertneville73


    OK, this is driving me nuts. I’ve looked at the other threads related to this and I’ve tried everything and it just wont work.

    Server = Ubuntu Linux, with Apache2 and PHP5,
    I’ve tried it on 3 different browsers on 3 different computers. All of these browsers work just fine for a hosted version of WP 2.1 – so I know it’s not the browser.
    I’ve downloaded the latest and greatest version of widgets (1.2.1). Still no-go. I’ve tried putzing with scriptaculous in terms of where it’s located, even tried plopping in the latest version of that tool…still no good (I’ve restored it back by the way).

    If I leave everything in /wp-includes/js/scriptaculous, then I get zero drag and drop activity. If I move the scriptaculous.js file up one directory, then the widget selected shows a different color as if it’s been selected, but it will not move.

    If I ctl-F5 the admin page and watch an error console, before I touch anything, I see ‘Position.absolutize is not a function’ – which as far as I can tell, is a method contained in prototype.js…I’ve tried moving that file up one directory too to no effect.

    If I try to move something, the error console shows a BUNCH of ‘Position.prepare is not a function’.

    Seems like something has not been properly included or something and I’m pulling my hair out here. Anybody got any bright ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin


    a) Redownload WordPress 2.1. Extract the wp-includes/js/scriptaculous/* files from there and put them where they belong (that same directory). Moving them around will *break the blog*, so don’t do that.

    b) Download the latest widgets code (1.2.1a or something like that). Put it in wp-content/plugins/widgets/widgets.php.

    c) Download this file and put it in wp-includes/js/scriptaculous/wp-scriptaculous.js . It was a missing file in the original 2.1 release. Lack of it might cause issues.

    d) If you have *any* scriptaculous stuff in the widgets directory, delete it.

    e) While looking at the widgets page, hit CTRL-F5 to refresh your browser. Might also want to clear the browser cache beforehand.

    That will fix it, if you do all of those steps. But moving things around randomly won’t help at all. So stop doing that.

    Thanks for the reply Otto. I don’t normally resort to hacking, but I’d already tried everything you just listed…with the exception of downloading the wp-scriptaculous.js file.

    Just for completeness, I did everything you mentioned, in order. Since it’s not a live site, I redid the whole WP install, just to make sure and disabled all other plugins to rule-out that possibility.

    Cleared the cache and did the ctrl-f5 as mentioned…I’m back to the beginning where the mouse cursor changes on a mouse-over, but click and drag doesn’t function.

    Error console is giving me: ‘uncaught exception: requires the Prototype JavaScript framework >= 1.5.0’. Now, this is what I was seeing before. When I inspect the protoype.js file, it says that it’s: “Version: ‘1.5.0_rc0′”.

    All of the files are in the scriptaculous directory, there are no .js files in the widgets directory. All .js files are -rwxr-xr-x, so I don’t think it’s a permissions issue.

    I know it’s not the ‘right’ way to solve whatever the underlying problem may be, but on a hunch, I moved the protoype.js up to the wp-includes/js directory and…..presto it works just fine now. I think I was on the right hack-track before but I was missing the wp-scriptaculous.js file or I just needed to reinstall everything from scratch. Either way, something’s definetly not right with WP2.1 + Widgets, out of the box – though I suppose that it could be something quirky about my install, though I don’t readily see what that could be…

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    prototype.js is indeed supposed to be in the wp-includes/js directory. Another copy of the same file is also in the scriptaculous directory. I think you may have just gotten your files misplaced and such. Take a look at the 2.1 zip file and see where they’re all supposed to go.

    You’re right. I re-downloaded WP2.1 and it had it in the right spot. Something was funky with my original tar file and it was missing a bunch of files.

    Funny enough though, it turns out that there was another problem with one of my plug-ins: namely the king framework. They include a lite version of prototype.js in their plugin that seemed to stomp on the default one and it didn’t have all of the necessary functions so I had to change one of the files in that plugin to include the default version of the file instead of the one included with the plugin or I saw the same behavior.

    I think I have everything playing nice now.

    I just wanted to add for future reference that I had this same problem, and in my case, it was also a King Framework plugin that turned out to be the culprit.

    I have King Framework working successfully on some other blogs, but for some reason it was making this one throw fits. Once I narrowed it down to the King Framework widget, I just replaced it with another plugin that would accomplish the same goal and didn’t debug any further.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Widgets Admin Can’t Drag and Drop’ is closed to new replies.