Support » Plugin: Author Avatars List/Block » Widget settings unset on save

  • Hi there

    I’m using the widget and each time I save it, all the Display Options return to the checked state. This means the next time I want to save the widget (for example when I add a new author to the whitelist), I have to uncheck all the unwanted options again. Not a major big deal, but an annoyance you might like to know about.

    As a workaround, I was going to use the shortcode, but there doesn’t seem to be the option to show a link to the authors last post. I rather link this option in the widget. Are there any plans to offer the same functionality?

    Cheers

    • This topic was modified 5 months, 1 week ago by baindesign.
    • This topic was modified 5 months, 1 week ago by baindesign.
    • This topic was modified 5 months, 1 week ago by baindesign.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Paul Bearne

    (@pbearne)

    Hi

    I did spot this is in the last block of testing and haven’t been able to get fixed

    Will try to solve ASAP

    The shortcode should take a user_link value of last_post

    Paul

    Will try to solve ASAP

    Great! I’ll keep my eyes peeled for an update.

    The shortcode should take a user_link value of last_post

    Setting the user_link value in the shortcode to last_post changes the link on the user’s name. What I would like to do is show an additional link underneath the user’s bio, similar to what can be achieved using the widget.

    As this functionality is already in place in the widget, perhaps it’d be relatively easy to extend it to the shortcode?

    Thanks

    Any update on this? I tried to edit my page and now it’s completely broken. Display settings won’t persist.

    I have the opposite problem using the Gutenberg Avatar Lists block.

    Every time I go to open the page in edit view again, certain settings are unset and I have to reset them before saving the page again.

    I have Select by Role(s) selected but the checkbox I checked (author) is unchecked.

    I also had selected to show name and bio with the avatar but these items are also unchecked.

    All of the settings below these checkboxes remain as I previously selected.

    I don’t know if the following is relevant but I also have debugging turned on and these notices appear when I edit the page containing this block or the page itself:

    Notice: rest_validate_value_from_schema was called incorrectly. The “type” schema keyword for can only be one of the built-in types: array, object, string, number, integer, boolean, and null. Please see Debugging in WordPress for more information. (This message was added in version 5.5.0.) in /home/de3xwjgi/public_html/wp-includes/functions.php on line 5225

    Notice: rest_validate_value_from_schema was called incorrectly. The “type” schema keyword for can only be one of the built-in types: array, object, string, number, integer, boolean, and null. Please see Debugging in WordPress for more information. (This message was added in version 5.5.0.) in /home/de3xwjgi/public_html/wp-includes/functions.php on line 5225

    • This reply was modified 2 months, 3 weeks ago by NBH707. Reason: changed first sentence to refer to opposite problem
    Plugin Author Paul Bearne

    (@pbearne)

    Sorry, I will try to find time to give this some TLC ASAP
    Thanks for the update

    Plugin Author Paul Bearne

    (@pbearne)

    Hi all

    I found a problem with the object type in the Gutenberg block code and pushed a fic in 2.1.2 to fix this

    I could recreate the display settings resetting/not storing can you please test in case I also fixed that?

    If not can I have PHP and WP versions and any other info that you can thing of to help me find and fix this?

    Paul

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.