WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Widget Plugin not working

[Resolved] Widget Plugin not working

Viewing 15 replies - 1 through 15 (of 26 total)
  • I get same exact error: Sortable not defined.

    For this particular error (Sortable is not defined) let’s start gathering info on it so the problem can be tracked down. This is the configuration where I’m seeing this (two other setups have no issues with the plugin):

    WordPress version: 2.0.2
    Web server: IIS 5.1

    Yeah, same exact error. As I mentioned in my other post regarding it, it seems to be due to the header code – sidebar_admin_head() – not being called. If I manually put a function call to the header in the code, like so:

    <?php sidebar_admin_head() ?>

    (I added it at line 547 in widgets.php for those interested) – it’ll work.

    WordPress: 2.02
    Web server: Apache 2.0.55 on Windows XP (test box)
    PHP version: 5.1.1

    WordPress 2.0.2
    Apache/2.2.0 (Win32)
    PHP/5.1.1

    Still get Sortable not defined error.

    Well so far it appears to be a platform (OS) issue. And thanks for the fix karrde.

    Yes! Thanks karrde!

    Apache 2.0.55 Win32 PH/4.4.1
    Windows XP Pro
    PHP 4.4.1 (cgi-fcgi) (built: Oct 30 2005 12:45:44)
    Wordpress 2.0.2

    The fix mentioned above didn’t work.

    It worked for me except that I can’t add extra (more than 1) RSS or Text widgets…

    Yeah, it was a quick and dirty fix so that I could start testing widget integration with the theme I develop. I imagine that whatever’s causing it to break under Win32 is also breaking the RSS and text widget issue that RobertGX is having.

    My Widgets plugin is not working. I did install the files in the right place. In the account I have through my Web site it will not show the Sidebar Editor meny in the Presentation meny as the ReadMe file for the Widget states.

    Dos this plugin work when the blog is not hosted by WordPress but is hosted by another host, such as my own Website?

    Milt

    Of course you know that in the post above I meant MENU and not “meny”… it is late… Sorry!

    does the Widgets plugin work when the blog is not hosted by WordPress.com but by another host such as my web site?
    You can read the post above as well to know what I am talking about.

    Milt

    Thanks for the fix karrde! It worked for me.

    But, I don’t think this problem is dependent of OS, but something else. This plugin didn’t work for me either (after fix karrde mentioned it worked), and my host is running CentOS Linux and Apache. And like with RobertGX, I can only add one text and rss widget. But that’s enough for me as long as I can make my theme compatible with widgets and continue somehow (I hope they release new version sometime).

    I’ve got a full fix. Apparently the ZIP file wasn’t updated. So if your using IIS then this fix will work. (I got it from Andy)
    http://svn.wp-plugins.org/widgets/trunk/widgets.php

    For more information check out my blog post about it:
    http://betzster.no-ip.org/Blog/index.php/2006/04/03/sidebar-widgets-plugin-iis-fix/

    betzster: Thanks! Works perfectly. (But the link to your post doesn’t.)

    Yep, the new version as linked above by betzster fixes the problem for me also.

    Hurrah!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] Widget Plugin not working’ is closed to new replies.
Skip to toolbar