Support » Fixing WordPress » Widget panel trouble after upgrade: some drag/drop busted, changes won’t save

  • Resolved dduane


    Folks — After searching, I’ve found other posts about problems similar to this, but none of the resolutions noted in other such messages have worked for me. I could use some assistance.

    I’ve just upgraded to 2.3.1 from 2.0.2. I made sure the PHP and MySQL versions were adequate, then followed the extended upgrade instructions for upgrading from 2.0.x to the letter, including the deactivation of all plugins and the deletion of the wp-content/plugins/widgets folder, understanding that the old Widgets plugin and the new core widget ability conflict.

    The upgrade went swimmingly. Everything seemed fine. But now, after a few days’ tinkering and the installation of a new 3-column theme (my old 3-column Leaves Revamped one didn’t display correctly with 2.3.1), trouble has begun.

    Attempts to add/remove widgets using the Widget subpanel fail in two ways: (a) Some widgets, when dragged and dropped on the palette, will not stay dropped: they return to the left-sidebar panel from which they came. (My right sidebar is empty.) Others do successfully drop and stay where they’re put. However, this does me no good, because (b) on hitting the “save changes” button, I get the Firefox equivalent of a white screen, and nothing more. (I’ve I tried doing the same edits in Explorer. Same result.)

    Editing the widgets (opening, changing contents, closing) seems to work OK. But there’s no way to tell for sure, because the save never completes. And the problem persists no matter what theme I use. I have again deactivated all plugins. The problem remains.

    Other topics discussing this kind of problem have suggested that something might be wrong with the .htaccess in the new wp-admin directory, or that it might need an .htaccess file installed in the first place. I have added the file and made those suggested changes, with no result: so have removed it/them.

    Still other messages have suggested that a complete removal and reinstall of “all widget-affiliated files, including the Javascript” would be necessary. I have absolutely no problem with this concept. (At this point all I want to do is clean out the widget-based sidebar contents and go back to hard-coding the sidebar.php file in the theme.) But can someone clue me in on exactly which files these would be? — as I’ve spent a couple of days on this now and am getting nowhere. (Oh, and the blogroll’s not displaying, either. Don’t ask me why.)

    Anyway, many thanks in advance for your help!

    Best — Diane

Viewing 1 replies (of 1 total)
  • Problem’s resolved. For those who may read this while trying to solve their own problems: Make sure that your text widgets don’t have any Javascript in them which may have become malformed or otherwise messed up when being pasted in, or during an upgrade. I stripped all the Java out of my text widgets, and once it was gone, the widget page saved correctly. Then added the Java back in again, a piece at a time, and everything continued to work correctly.

    Whatever your problem may be, good luck with it…

Viewing 1 replies (of 1 total)
  • The topic ‘Widget panel trouble after upgrade: some drag/drop busted, changes won’t save’ is closed to new replies.