Support » Plugin: Widgets on Pages » widget on pages doesn't work after wp 4.0 update

Viewing 15 replies - 1 through 15 (of 25 total)
  • I have the same problem…! Have you found a solution?

    Thea

    Not yet, even if everything seems to be fine, nothing happens

    Andrew

    Got the same problem! Double-checked everything, everything is correct, but WOP doesn’t work. The same – it all happened after WP update

    I found one error and one potential problem.

    If you feel like editing the plugin, open widgets_on_pages.php in Plugins > Editor, find the widgets_on_template function, and replace

    $arr = array(id => $sidebar_name );

    with

    $arr = array('id' => $sidebar_name );

    (notice the single quotes around id)

    and near the end, replace

    add_action('admin_init', 'reg_wop_sidebar');

    with

    add_action('widgets_init', 'reg_wop_sidebar');

    which is the proper hook.

    Apologies to the developer if I’m overstepping but this plugin has not been updated in almost two years. I would gladly adopt it if you are so inclined.

    I just did that Chris Dillon, and now my site does not work…???!!!

    It says: Fatal error: Call to undefined function is_plugin_active() in /var/www/kropsfabrikken.dk/public_html/wp-content/plugins/black-studio-tinymce-widget/black-studio-tinymce-widget.php on line 140

    ???

    What do I do to get my site back? Im a beginner at this. What is line 140??

    Change

    add_action('widgets_init', 'reg_wop_sidebar');

    back to

    add_action('admin_init', 'reg_wop_sidebar');

    and I’ll do some more testing.

    Unfortunately, no result 🙁

    That was for Theafrost to get their site working.

    Thanks, Chris! I meant the whole problem, not that one, Thea wrote about. Hope anybody will find a solution soon.

    My hunches were wrong so disregard my earlier advice. Todd told me he is working on an update.

    Ok, thank you for trying. My site is still just “gone” and shows the message that I posted. Dont know what to do to get it back…? If you go to http://kropsfabrikken.dk/ you see what I mean. It also shows on my wp admin page…

    Thank you anyway Chris,
    i hope Todd will fix the problems.
    Unfortunately, every wp update i cross my fingers and hope everything will still work.

    Tell me Thea, does your site give that problem after the wop plugin editing?
    it’s strange that it gives back the whole path

    I just changed

    add_action(‘admin_init’, ‘reg_wop_sidebar’);

    to

    add_action(‘widgets_init’, ‘reg_wop_sidebar’);

    And now I can not change it back…

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘widget on pages doesn't work after wp 4.0 update’ is closed to new replies.