Support » Plugin: Category Posts Widget » Widget not showing up at all

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Daniel Floeter

    (@kometschuh)

    It’s possible you have no attached feature image to your posts and select the option in the Filter panel > “Exclude posts which have no thumbnail”?

    It is possible you have posts to show and not delete all after place the widget?
    Please try the Filter > Category “All” if another category have posts.

    It’s an understanding problem and the doc can help you: http://tiptoppress.com/category-posts-widget/documentation-4-7/

    The option in the Filter panel > “Exclude posts which have no thumbnail” is unchecked.

    I changed it to Filter > Category “All” and it did show the posts from “Uncategorized” but it’s still not showing the posts from “Featured”. I did make sure that the category for the “Featured” is created and has 3 posts in it.

    Plugin Author Daniel Floeter

    (@kometschuh)

    Mmmh, have you other widgets which you can deactivated?

    In some cases this helps.

    Then please try to deactivate, delete and make a clean new install with our widget again?

    Your widget was the only one activated. I also did delete and installed the widget again but it’s not working… I even created a new category, assigned a post to it and then, changed the filter to that category but it’s still not showing… The theme I’m using is a child theme of the Monday theme: https://accesspressthemes.com/wordpress-themes/the-monday/

    and here’s the documentation: http://doc.accesspressthemes.com/the-monday/

    Plugin Author Daniel Floeter

    (@kometschuh)

    I get it, but I don’t think it’s our widget, because in the last issues it depends on side effects.

    It is all I can say at the moment. Please try my proposal above?

    Best make a new clean WordPress installation and make step by step with other widgets what works and what is the issue.

    We are interested in, why there is a relation.
    Possible is a filter set by another widget.

    Plugin Author Daniel Floeter

    (@kometschuh)

    Last is to change the used Theme?

    Then we have to check the options of the widget.
    You checked the show Thumbnail option?

    I think I narrowed down the problem. What’s not displaying are the posts from the Custom post types that I created. I’m looking in that right now…

    I already narrowed down the problem. It’s not the theme, or your widgets. It’s the Custom Post Types. Here’s the problem I’m trying to resolve in WordPress development: http://wordpress.stackexchange.com/questions/261957/custom-post-type-posts-not-showing-in-category.

    So far, some articles I’ve read said that when I register custom post type, I will also need to register taxonomies. I’m trying to figure how to do that in functions.php, but I thought it’s already registered when I added 'taxonomies' => array( 'category', 'post_tag' ), in my Custom Post Type:

    // Register Custom Post Type
    function tvs_post_type() {
    
    	$labels = array(
    		'name'                  => _x( 'TV', 'Post Type General Name', 'text_domain' ),
    		'singular_name'         => _x( 'TV', 'Post Type Singular Name', 'text_domain' ),
    		'menu_name'             => __( 'TV', 'text_domain' ),
    		'name_admin_bar'        => __( 'Post Type', 'text_domain' ),
    		'archives'              => __( 'Item Archives', 'text_domain' ),
    		'parent_item_colon'     => __( 'Parent TV:', 'text_domain' ),
    		'all_items'             => __( 'All TVs', 'text_domain' ),
    		'add_new_item'          => __( 'Add New Post', 'text_domain' ),
    		'add_new'               => __( 'Add New Post', 'text_domain' ),
    		'new_item'              => __( 'New Item', 'text_domain' ),
    		'edit_item'             => __( 'Edit Post', 'text_domain' ),
    		'update_item'           => __( 'Update Post', 'text_domain' ),
    		'view_item'             => __( 'View Post', 'text_domain' ),
    		'search_items'          => __( 'Search Posts', 'text_domain' ),
    		'not_found'             => __( 'No posts found', 'text_domain' ),
    		'not_found_in_trash'    => __( 'Not posts found in Trash', 'text_domain' ),
    		'featured_image'        => __( 'Featured Image', 'text_domain' ),
    		'set_featured_image'    => __( 'Set featured image', 'text_domain' ),
    		'remove_featured_image' => __( 'Remove featured image', 'text_domain' ),
    		'use_featured_image'    => __( 'Use as featured image', 'text_domain' ),
    		'insert_into_item'      => __( 'Insert into item', 'text_domain' ),
    		'uploaded_to_this_item' => __( 'Uploaded to this item', 'text_domain' ),
    		'items_list'            => __( 'Items list', 'text_domain' ),
    		'items_list_navigation' => __( 'Items list navigation', 'text_domain' ),
    		'filter_items_list'     => __( 'Filter items list', 'text_domain' ),
    	);
    	$args = array(
    		'label'                 => __( 'TV', 'text_domain' ),
    		'description'           => __( 'tv information pages', 'text_domain' ),
    		'labels'                => $labels,
    		'supports'              => array( 'title', 'editor', 'excerpt', 'author', 'thumbnail', 'comments', 'custom-fields', ),
    		'taxonomies'            => array( 'category', 'post_tag' ),
    		'hierarchical'          => false,
    		'public'                => true,
    		'show_ui'               => true,
    		'show_in_menu'          => true,
    		'menu_position'         => 5,
    		'show_in_admin_bar'     => true,
    		'show_in_nav_menus'     => true,
    		'can_export'            => true,
    		'has_archive'           => true,		
    		'exclude_from_search'   => false,
    		'publicly_queryable'    => true,
    		'capability_type'       => 'page',
    	);
    	register_post_type( 'tv', $args );
    
    }
    add_action( 'init', 'tvs_post_type', 0 );

    Hey. I think I figured it out. Your widget is probably based on the WP_Query which has default post type set to post. Therefore, it was unable to display the posts I’ve created in Custom Post types…

    • This reply was modified 1 year, 6 months ago by  kikib.
    Plugin Author Daniel Floeter

    (@kometschuh)

    You can try our premium widget on localhost which supports Custom Post Types: http://tiptoppress.com/free-trail-localhost/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Widget not showing up at all’ is closed to new replies.