Support » Plugins and Hacks » Widget Logic » widget-logic error

widget-logic error

  • if i try to swich to php 5.3.x
    i’ve got this error on both sidebar before the widget menu (correct)
    Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in /web/htdocs/www.istruzioneveneto.it/home/wpusr/wp-content/plugins/widget-logic/widget_logic.php(270) : eval()’d code on line 1

    I think there is a problem on custom sidebar code


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author alanft


    Your widget logic has a syntax error in it that may have been valid in the previous version of PHP

    i thought too, but is very difficult find the error

    there where 7 occurrance of this error
    after change of widget logic preferences there where only two on both sides before the correct widget so i think the error is in theme syntax nobody has the same problem?

    Plugin Author alanft


    thanks for the screenshots, but I can’t tell a lot from them. Can you identify which widgets are causing the problem – and if so what’s the WL code in them.

    You could try saving out the WL options (for safe keeping) and blank each widget in turn temporarily to see which code produces the errors.

    I’m seeing the same error, right after I upgraded to WordPress 3.4.1. Worked fine just before the upgrade. I tried re-installing WP 3.4.1, as well as deleting and re-installing Widget Logic, no help. Any ideas/suggestions?

    Disregard, I found the issue. Was using the following conditional tag:
    is_single( '17' )

    However, somehow the leading quote mark before the post number got deleted. Restoring that fixed it. Incidentally, using no quote marks worked, too.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘widget-logic error’ is closed to new replies.
Skip to toolbar