WordPress.org

Support

Support » Plugins and Hacks » Music Affiliate Pro » [Resolved] Widget links not showing

[Resolved] Widget links not showing

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Brady Vercher

    @bradyvercher

    Not all retailers provides widgets and the ones that do may only provide them for certain entities (albums, artists, or songs).

    Clicking the result and inserting a link is the designed behavior when a widget isn’t available. The link in the editor won’t have your affiliate information since it’s converted when the post is displayed. You’ll have to view the post or page on the frontend to make sure your affiliate information is being added to the links.

    Trishah

    @trishahdee

    Thank you for the reply Brady!

    I have inserted the links by clicking the search results but when I view the links in the frontend they don’t seem to be my affiliate links. Here is a page I’m working on to try to get the links to work.

    Link Test Post

    The links are marked. The Amazon widget is working.

    Plugin Author Brady Vercher

    @bradyvercher

    The eMusic and Rdio affiliate programs aren’t currently supported in this version of the plugin, so those won’t be converted.

    iTunes should work, but it looks like they’re returning a secure link (https://) for some reason. Try changing that to http:// instead and see if it adds the affiliate information.

    Trishah

    @trishahdee

    Changing the plugin-created iTunes link from https:// to http:// does indeed change the url to the affiliate link.

    So I tried changing my affiliate wrapper in the plugin to https:// so it matches the generated link but that does not work.

    Does this mean you must update the plugin to correct this or can we do it some how?

    Plugin Author Brady Vercher

    @bradyvercher

    Go ahead and keep the regular http:// protocol for your wrapper–I’m not if changing that will work. I hadn’t seen the secure iTunes links before, but that was something that needed to be updated in the code, which I went ahead and took care of, along with a couple of other minor bug fixes.

    Visit your plugin page or the updates page in your dashboard and it should let you download the new version. Hope that helps!

    Trishah

    @trishahdee

    I updated but… no it didn’t 🙁 It doesn’t matter now if I use the https or http in the plugin-created link. Neither works.

    Plugin Author Brady Vercher

    @bradyvercher

    Do you still have the wrapper saved in your settings?

    Trishah

    @trishahdee

    Yes. I verified that I had the correct one.

    Plugin Author Brady Vercher

    @bradyvercher

    It appears to be working fine on my installation and I can’t see any reason why it shouldn’t be working.

    Looking at your source, is that affiliate section still in the content? Or are you displaying that some other way?

    Trishah

    @trishahdee

    Ahhh… for some reason when the link is inside my custom fields area it doesn’t change to the full link 🙁

    If I add a class to the generated link then it works and I can css it from there.

    The other custom area I have on the page is done with custom fields. Is there a way to make the iTunes link generate when in a custom field?

    Plugin Author Brady Vercher

    @bradyvercher

    You would need to apply a filter to the content in your custom field so those links can be converted. There’s not a way to automate it, so you would need to modify your template to run your custom field through the_content filter. Something like this:

    echo apply_filters( 'the_content', $customfield );

    That might cause issue depending on how other plugins are using that filter, but you can give it a shot.

    Trishah

    @trishahdee

    It worked! “itunes_affiliate_link” is the name of both the custom field and the css ID. Here is the code that works and only effects the iTunes link:

    if ( get_post_meta($post->ID, 'itunes_affiliate_link', true) )
    echo "<div id='itunes_affiliate_link'>";
    echo apply_filters( 'the_content', get_post_meta($post->ID, 'itunes_affiliate_link', $single = true) );
    echo "</div>";

    Thank you so much for working with me on this!

    BTW, it still might be nice to add a css class to the links so we can easily make them look like buttons if we want… Just a thought. 😀

    Plugin Author Brady Vercher

    @bradyvercher

    Glad you got it working! I think the same suggestion was made regarding classes, so I’ll put it on the list of new features. Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Widget links not showing’ is closed to new replies.
Skip to toolbar