Support » Plugins and Hacks » [Resolved] Widget isn't showing up

[Resolved] Widget isn't showing up

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Mike


    Which themes have you tried? I’d like to see if I can replicate the problem.

    i tried twenty-eleven

    Plugin Author Mike


    That’s crazy strange. Do you have at least the minimum number of headings? Are you using any special character sets or just plain ascii?

    ok let me clarify.
    twenty eleven is bad test case cause it doesn’t have a sidebar for single.php

    i’be been using bloxy two

    yes i’m sure i have the minimum number of headings because it displays fine in the post content. should be plain ascii or whatever the default is.

    i’m happy to try another theme if you want to get a basic reference test.

    just switched to coraline, doesn’t work there either.

    to recap:
    TOC shows fine in post body if widget is there or not
    set widget to only show widget, TOC does not appear in post body
    widget never appears

    another bug

    if i add the widget, check the only show as widget option, then delete the widget, the TOC doesn’t appear for any articles (post or pages). I then need to add the widget back to get the toc to appear in the post body, and as long as i don’t check the only show option the body continues to show the TOC.

    clearly the option is persisted across the widget’s lifespan. adding the widget again resets the option.

    Plugin Author Mike


    That’s concerning that it’s not appearing in the sidebar when you add the widget. It definitely does for me with Twenty Eleven (using one of the footer widgets). I’ll give Coraline a try.

    What other plugins have you got enabled?

    The other bug is a known issue and was identified in the release note when the widget made its first appearance. Haven’t found a good way to unset it on widget removal yet.

    during my tests it is the only enabled plug-in
    I’ve also made it the only widget

    in twenty eleven it doesn’t appear in footer either for me.

    this is a multisite, and my blog isn’t the main site.

    Plugin Author Mike


    Nothing out of the ordinary. I use it in prod on multisite installs ok.

    Are you able to send me the content you use as your test?

    Are you using linux? Apache/nginx? Which version of PHP?

    running on ubuntu
    apache 2. something
    php 5.3.18

    the dead simplest test exhibits the problem

    <h2>header 1</h2>
    <h2>header 2</h2>
    <h2>header 3</h2>
    <h2>header 4</h2>
    Plugin Author Mike


    Architecture looks normal. I just tried Coraline and it’s ok for me.

    Does any other type of widget work?
    Do you have anything in wp-content/mu-plugins?

    all the basic widgets work fine
    there is no mu-plugins folder
    is there a debug mode or something i can turn on, or logging of some sort?

    Plugin Author Mike


    You can add the following into your wp-config.php file but I’m not sure if it’ll give you anything useful with TOC+

    define('WP_DEBUG', true);

    I have it enabled on my platform to ensure there are no warnings/notices, etc.

    I’m out of ideas as to what could be causing it. If I was in this situation, I would be editing toc.php to see what is going on. If you want to try, I would concentrate on the following area:

    function widget( $args, $instance )

    so here’s the problem.
    the widget happens before certain processing takes place. That processing is putting in newlines into the content string

    so for the widget, the regular expression is matching against one line of text, thus only finding one h2 tag for the entire doc, where the post body it’s finding a bunch cause they are all newlined out.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Widget isn't showing up’ is closed to new replies.