WordPress.org

Support

Support » Plugins and Hacks » Author Spotlight (Widget) » [Resolved] Widget installed, but doesn't show up on the webpage

[Resolved] Widget installed, but doesn't show up on the webpage

  • Hi,

    I have Author Spotlight installed, activated and placed on the right sidebar between other widgets. I’ve filled in my profile. I also got a Gravatar. But Author Spotlight doesn’t show up on my blogpage. The other widgets do.

    These are the versions:
    Wordpress 3.5.1
    Atahualpa 3.7.11
    Author Spotlight 3.2

    Can you please help me?

    Thanks,
    Hans

    http://wordpress.org/extend/plugins/author-profile/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Debashish

    @debashish

    You must provide additional details so that I could understand your problem. Can you provide the website/blog URL of the page you are experiencing the issue? Is it the home page (Widget is not supposed to work here) or a page for Post (Single) or a WordPress Page where the widget doesn’t display anything?

    Hi Debashish,
    Thanks for your response. You helped me already!
    Author Spotlight does show up on the sidebar of all the other pages but not on the sidebar of the homepage itself!!
    I checked the FAQ but this is not mentioned.

    Since the basic setup of WordPress is to put the blog-articles on the homepage, this widget should be able to detect the author in order to display the profile. right?
    In any case, I would like to have my authors profile in the sidebar of the articles-page.

    Is it possible to arrange this or any work-around?
    The URL is: http://www.life20.nl

    Thanks!
    Hans

    Plugin Author Debashish

    @debashish

    Hello Hans,

    The widget was never designed to work that way, it was meant to show “meta-data” of the post/page, i.e. information about a particular post (in this case the author profile). The FAQ does hint towards this by saying that its meant to display Author(s) for a “Single” post, not multiple.

    There is certainly a work-around for which you must edit the widget code. Change line 107 from:

    if(!$isHome && (is_single() || is_page()) && $authordata->ID){

    to something like:

    if($authordata->ID){

    Just remember that this is not the way I designed the Widget, its not supposed to be used for multiple posts. Also note that with the check removed the Widget would potentially display on all sidebars and I cannot guarantee a “desired” behavior.

    Debashish,

    Thanks again. It works!
    I changed line 107 into if($authordata->ID){ and the widget now appears on my home page.
    I have only one sidebar, so this is the “desired” behavior.

    Many thanks for your help!

    Regards,
    Hans

    Plugin Author Debashish

    @debashish

    Glad to know this Hans.

    Hi Debashish,

    I too am interested in having the profiles on my homepage: http://www.hrwc.org.

    However this home page has multiple blogs on it, with multiple authors. I am interested in showing the profile of the most recent author only. With your fix above it displays the author of the oldest post on the page.

    Would this be possible?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Widget installed, but doesn't show up on the webpage’ is closed to new replies.
Skip to toolbar