WordPress.org

Forums

[resolved] Widget error text display but only on Firefox (3 posts)

  1. pinkbeats
    Member
    Posted 4 years ago #

    I've just published my first post for about six weeks on my blog but I'm getting this error text displayed in my widget sidebar when viewing using Firefox (3.6.8 on a mac):

    Warning: filemtime() [function.filemtime]: stat failed for /.../pinkblog/wp-content/widget-cache/c5ab285825746049372ba5f38a47b333/090b71b1db87a6185c02373fb75516ad in /.../pinkblog/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 40

    Warning: fopen(/.../pinkblog/wp-content/widget-cache/c5ab285825746049372ba5f38a47b333/090b71b1db87a6185c02373fb75516ad) [function.fopen]: failed to open stream: No such file or directory in /.../pinkblog/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 131

    Warning: flock() expects parameter 1 to be resource, boolean given in /.../pinkblog/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 132

    Warning: fclose(): supplied argument is not a valid stream resource in /.../pinkblog/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 137

    However, it only displays when viewing the home page and only on Firefox - if I view a single post in Firefox, the error text disappears and the sidebar displays normally. I also tested by visiting the home page using both Chrome and Safari and no error text appears. I've tried clearing the widget cache but that makes no difference, I've also tried disabling the only change since my last post and since I last viewed by blog without any error (yesterday), which was the installation of the FD Feedburner plugin but that doesn't make any difference.

    Any suggestions welcome, thanks in advance.

  2. pinkbeats
    Member
    Posted 4 years ago #

    Bah! It's corrected itself - Firefox playin' up again, I swear there's something delayed or weird going on with it's caching. Nothing to see here, move along please...

  3. pinkbeats
    Member
    Posted 4 years ago #

    Not sure I follow - are you saying I shouldn't even have bothered to post about this problem in the first place? I didn't know what widget was causing the 'problem' and then discovered it was only specific to Firefox which seemed a bit strange. I'm only guessing that it's something to do with the way Firefox was caching information but that's just a guess. This information could be useful to anyone else who may have the same (temporary) issue as when I did a search using the query "Warning: filemtime()" none of the results offered any guidance.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags