Support » Plugins » Widget Drag and Drop doesn’t work

  • I did a search on this issue and couldn’t find anything, so here goes…..

    I got WP up and running on my site. I can change themes, post, edit, customize, etc. The only thing I cannot do is use my widgets. I activated the plugin, went to “Presentation -> Sidebar Widgets” and when I try to drag, it just highlights the text.

    This happens in IE 6, Opera 8.5, Firefox 1.5. I’m running WinXP. All browsers and XP have all the latest patches.

    Any takers?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Make certain that you moved the scriptaculous directory that came with the widget plugin into the /wp-includes/js directory. Yes, yes, I know the documentation says it’s optional.. well, it’s not. Follow the install instructions with the widget plugin and it’ll work.

    Sorry for the late reply….work nights, so…..

    I just checked and it turns out I had copied the files to the js directory, not the scriptaculous folder. I’m doing so now and giving it a shot.

    Holy Snap! That did it! Thanks Otto!

    i had this problem also.. i had tried copy the scriptaculous folder to js directory,but it wont work.. actually,the widget runs okay before this, then suddenly it goes wrong after i install few more plugins.. i cannot think which plugin may caused it,thus i deleted all plugins(except the default one) including deleting all the tables created(in db) from those plugins.. until now, the widget still cannot be dragged n drop.. it is something related with wordpress cache?? although,i dont have any cache folder coz i dont install wp-cache.

    i was thinking to reinstall wordpress… i have tried also using other computers…

    im using wordpress 2.0.5, firefox 2.0, windows xp pro and my wordpress are installed on my own pc…

    hey guys..I have done both the steps but it is STILL not working 🙁

    please help!



    Hi, i have the same problem.

    I recently installed WordPress 2.1 (that came with the scriptaculous dir) and installed the widget.
    In any browser i cant drag n drop at all.




    I am also running on Apache and am having the same issue.

    Most current version installed of WP and of Widgets toolbar. They are enabled. Everything works — I just can NOT drag and drop from Internet Explorer 7 or Firefox 2.0.

    Javascript is enabled and my WP site is set for the lowest security setting.

    The JS folder also contains scriptaculous and it seems to be current.

    Any ideas?

    Sorry for the double post but I am seeing this one as a current issue.



    I have the same problem. I can’t drag the Widgets.

    Linux Server hosted by GoDaddy running wordpress 2.1




    I don’t have a solution, but there is a topic running about it here as well with some more detailed info.

    Please download the latest version of the Widgets plugin (just updated today – February 10, 2007)

    Version 1.2.1:



    Fixes one error, but also returns a new one in line 798 of themes.php (according to FireBug):

    Draggables is not defined
    Line 798

    Please take a look at it once again.

    Scratch that, when I reuploaded my js directory everything worked again, thanks!



    Installed latest version (FEB 10, 2007), have NEW wordpress 2.1 installation but SAME PROBLEM, widgets DRAG & DROP does not work in ANY of my browsers.
    Before the update DID NOT WORK but had no errors on page, now with the new version of widgets plugin I got from IE :

    Line:235 AND 640
    Object does not support this property or method

    System running on servers under LINUX & PHP 5.0 and my wordpress blog is at

    Please fix it, or use another method (better) to add/remove widgets because I’ve found many good out there but can’t use them!!!

    PS : I’ve seen windows of the widgets in action at the screenshots but mine are not arranged like that! I’ve got a capture of Explorer’s window with the error and the drag & drop not working. See it at

    Greetings from GREECE 😉



    Well when I looked really hard into my jsfolder at the server, somehow the folders where all missing, so I manually put the folders among them “scriptaculous” and didn’t it work really well after that;-) Check your folders in the js folder and see if that is not your problem too!



    Updates to latest version of widgets AND NOW EVERYTHING WORKS..!!! Thanks for releasing widgets!



    I WANTED TO SAY : Updated to latest version of widgets AND NOW EVERYTHING WORKS..!!! Thanks for releasing widgets!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Widget Drag and Drop doesn’t work’ is closed to new replies.